Revised July 15, 2019, version 5.14.303

PS Suite EMR software and related products and services are owned by TELUS. PS Suite EMR and TELUS Health are trademarks of TELUS.

The patients, physicians and circumstances depicted within this manual are fictitious. Any resemblance of any sample data or screenshots to any actual person, whether living or dead, is purely coincidental and unintentional.
# Table of contents

Custom forms .................................................................................................................. 6
  Inserting and filling out custom forms in patient charts ........................................... 8
  Viewing, emailing or printing custom forms ................................................................. 8
  Collapsing custom forms in progress notes ................................................................. 10
  Importing custom forms .............................................................................................. 10
  Exporting custom forms ............................................................................................... 12
  Editing custom forms with the basic editor ................................................................. 12
  Toolbar custom forms .................................................................................................. 14
    Activating toolbar custom forms with reminders ..................................................... 14
    Using toolbar custom forms ...................................................................................... 16

Creating and designing custom forms ........................................................................... 18
  Navigating the forms editor ......................................................................................... 18
  Drawing toolbar ........................................................................................................... 19
  Properties pane .............................................................................................................. 21
  Name property .............................................................................................................. 21
  Design best practices .................................................................................................... 22
    Tips for measuring and placement ........................................................................... 22
  Specifying properties for a custom form ..................................................................... 23
  Defining the page layout ............................................................................................... 25
    Setting the page height .............................................................................................. 26
    Setting the printer margins ......................................................................................... 27
  Choosing a method to build your form ......................................................................... 27
    Building a custom form from scratch ....................................................................... 27
    Building a custom form from an image .................................................................. 28
    Building a custom form from a PDF ....................................................................... 32
  Adding elements to a custom form ............................................................................. 36
    Selecting elements ..................................................................................................... 37
    Searching for elements .............................................................................................. 37
    Inserting text .............................................................................................................. 38
    Adding a shape .......................................................................................................... 44
    Adding a Picture element ......................................................................................... 46
    Adding a Graph element ............................................................................................ 49
    Adding a user interface element ............................................................................... 52
    Inserting a Page interface element ......................................................................... 58
    Adding a Flowsheet element ..................................................................................... 59
Adding a Signature element ................................................................. 61
Resizing individual elements .......................................................... 63
Resizing all elements and locations .................................................... 63
Aligning elements ........................................................................... 64
Reordering elements ......................................................................... 64
Defining user interface options as mutually exclusive ....................... 64
Applying tab order to multiple elements ......................................... 65
Defining events ............................................................................... 65
Making fields mandatory .................................................................. 69
Making sections collapsible ............................................................... 70
Adding instructions for using a custom form ...................................... 72
Setting defaults for a custom form .................................................. 73
Using values from a previous custom form ........................................ 73
Collapsing the custom form by default in patient charts .................. 73
Showing the custom form in patient reminders ............................... 74
Locking the EMR when viewing a custom form ................................. 74
Setting a default fax recipient for a custom form .............................. 74
Testing a custom form ..................................................................... 75
Editing an existing custom form ...................................................... 75
Viewing the revision history of a custom form ................................. 76
Attaching a custom form to letters .................................................. 77
Removing a custom form ................................................................. 77
Consultation request custom forms ............................................... 78
  Customizing Consultation Request Template custom forms ........... 79
Demographics custom forms ........................................................... 82

Designing toolbar custom forms ...................................................... 84
  Toolbar Template form .................................................................. 86
  Items within toolbar custom forms ............................................... 91
    Bill Supercode toolbar item ......................................................... 92
    Insert Diagram toolbar item ...................................................... 93
    Insert Custom Form toolbar item ............................................. 94
    Insert Letter toolbar item .......................................................... 95
    Insert Note toolbar item ............................................................ 96
    Insert Stamp toolbar item ........................................................ 97
    Letter to Patient toolbar item .................................................... 97
    Open URL toolbar item .............................................................. 98
    Perform Treatment toolbar item .............................................. 99
    Prescription toolbar item .......................................................... 99
    Search toolbar item ................................................................ 101
    Send Email toolbar item ........................................................... 101
    Send Message toolbar item ..................................................... 102
    Show Flowsheet toolbar item .................................................. 103
    Show Graph toolbar item ........................................................ 104
Track Form toolbar item .......................... 104
View Filter toolbar item .............................. 105
View Form toolbar item .............................. 107
View Handout toolbar item .......................... 108
List toolbar item ....................................... 109
Use as picker toolbar item ............................ 111
Show overdue items toolbar item ...................... 112
Show abnormal values toolbar item ...................... 113
Most recent date toolbar item .......................... 114

Troubleshooting custom forms ...................................... 116
Why does content appear shifted when printing a custom form? ................. 116
How do I prevent Xs in checkboxes from being clipped when printing a custom form? 117
How do I fix a printed custom form where the content cuts off and prints on a second page? .......................................................... 117
How do I make custom forms collapse by default when I open a patient Chart? ....... 117
How do I prevent users from using custom forms that are not finished? ................. 118
How can I reduce the size of a custom form that displays too large in patient charts? ... 118
What is the difference between inserting and viewing custom forms (F2)? ............ 118
How do I draw perfectly straight lines? ............................................. 118
I created a new custom form to replace an existing form. What should I do with the existing one? .......................................................... 119
Can I hide some parts of an image when my custom form is based on an image? ...... 119

Index .................................................................. 120
Custom forms

Custom forms are electronic versions of standard forms (such as a government form), with active fields that automatically populate data from the patient’s chart or enable you to enter data.

For example, in the following parking permit form, the patient name and address fields contain keywords that will be replaced by patient data.

Here is the form with the available patient information.
A basic editor enables all users to change default selections or the text on existing forms.

If you have other form needs, you can build the forms yourself if you purchase the appropriate licence and attend the custom form training course. Or, you can hire TELUS Health technical staff to build them for you. For more information, contact the PS Suite EMR support team.

**Special types of custom forms**

In addition to “regular” fillable forms, PS Suite EMR provides the availability to work with the following “specialized” custom forms. These have additional javascript code that enable additional functionality within the EMR.

- Toolbar custom forms (see "Toolbar custom forms" on page 14)
- Consultation request custom forms (see "Consultation request custom forms" on page 78)
Inserting and filling out custom forms in patient charts

You can insert a custom form in a patient’s chart. Once the form is inserted, it appears within a progress note and you fill out the form by changing default selections or the text. Once saved, the form becomes a permanent part of the patient’s chart.

These forms can often take up a lot of room in the progress notes. For information about options for saving space, see "Collapsing custom forms in progress notes" on page 10.

If you want to view and fill out a custom form, but don’t want to insert it in the patient’s chart, see "Viewing, emailing or printing custom forms " below

Steps

1. Choose Data > New Custom Form (Ctrl {Command} + Shift + i).

   To filter the list, type some characters from the form name or instructions in the field at the top, or scroll through the list. Select one of the custom forms to see a preview on the right and any instructions for the form.

2. Choose the form that you want, and click Choose This Form.

3. Modify any default selections or text, as required.

Viewing, emailing or printing custom forms

You can view and fill out a custom form without attaching it to the progress notes. This is useful when you don’t want the information to become a permanent part of the patient’s record. For example, you may want to print a growth chart to give to a patient’s parent.

In this case, the form opens in a separate window, populated with patient data. The form in this window looks more like a printed piece of paper than it does when inserted within a progress note in the patient chart. You can fill out other information in the form and then print it or attach it to the next email for this patient. When you are done, you have the option to either discard the filled out custom form or to add it to the patient’s chart.

Some custom forms may have been customized to lock PS Suite EMR when viewed. This security feature is useful if you want to allow patients to complete the form, ensuring that they don’t have access to the print and email options for this form, or the system itself. For more information about locking the system when viewing custom forms, see "Locking the EMR when viewing a custom form" on page 74.
If you add information to the custom form and print it (e.g., filling out and printing a lab requisition form), the custom form will close and there will be no record in your EMR that any of this has been done. At some clinics this is the desired behavior—they don’t want some forms increasing the size of their charts. However keep in mind that if the patient calls back a few days later because they lost the form; it will be difficult to reproduce exactly what was given.

**Steps**

1. From the **Records** file, choose **View > Custom Form (F2)**.

To filter the list, type some characters from the form name or instructions in the field at the top or scroll through the list. Select one of the custom forms to see a preview on the right and any instructions for the form.

2. Choose the form that you want, and click **Choose This Form**.

The form opens in a separate window with the fields populated with the patient data.

3. Complete or change any of the fields, if necessary.

4. If you want to print the form, choose **File > Print**.

5. When you are finished, click **Discard** or **Add to Notes**. If you made changes and choose **Discard**, you are prompted to confirm.

If the form is locked, click **Done**. An authorized user must then log into the system. Locked forms are always inserted in the progress notes.

The system automatically includes note and page headers, as follows:

If you print a custom form by clicking within the custom form and choosing **File > Print** (Ctrl {Command} +P), without first selecting (green bar) the note, no page or note headers appear in the printed form.

If you print a custom form, by selecting the note (green bar), or when including the form with a letter, a page header appears on each page and a note header appears only on the first page of the printed form.
Collapsing custom forms in progress notes

Custom forms can take up significant space in the progress notes. You can hide (collapse) them when you don’t need to view them to save space, and then open (expand) them again when needed.

You cannot collapse a form if the note is unfinished or marked for review. These notes have a blue or yellow bar in the left margin.

All custom forms created and provided by TELUS Health are set to collapse by default once you move away from the patient chart.

**Step**

- Double-click the note date and choose **Collapse**.

To show the custom form, click **Click to expand**.

Importing custom forms

You can easily add new custom forms to your list of available forms if you receive forms from a colleague or from TELUS Health.

To use the form, you must import custom form file (.cfm file) into your PS Suite EMR. You can import one or more files at a time.

**Steps**

1. Copy the custom form files (.cfm files) that you were given to a folder on the desktop of your computer. If you were given the files in a compressed or zipped file, double-click the .zip file to
unzip the folder (or right-click and choose to unzip).

2. In PS Suite EMR, from the **Records** window, choose **Settings > Edit Custom Forms**.

3. To import files by selecting them from a list, follow these steps:
   - In the **Forms** window, from the **File** menu, choose **Import Form(s)**.
   - Navigate to your computer’s desktop and double-click the folder that contains the custom form files.
   - Click the custom form in the list that you want to import.

   ![To import more than one file at once, click the first file, hold down the Shift key on the keyboard and then click the last custom file in the list. This will highlight all of the files within the list.](image)

   - Click the **Choose** button. If you are importing multiple forms at once, and depending on the speed of your computer, the import may take 30 seconds or more.

4. To import files by dragging and dropping, follow these steps:
   - Navigate to the desktop and double-click the folder that contains the custom form files to import.
   - Position both the folder window with your custom form files and the PS Suite **Forms** window that lists all of your existing custom forms side by side so that you can see both windows.
   - Drag the highlighted custom forms files from that folder on the desktop and drop the files in the custom forms window.

   ![To import more than one file at once, before you drag the files, click the first file, hold down the Shift key on the keyboard and then click the last custom file in the list. This will highlight all of the files within the list.](image)
5. A message informs you whether the import was successful.

Exporting custom forms

If you have created your own custom forms, you can easily share them with other PS Suite users.

Steps

1. From the Records window, choose Settings > Edit Custom Forms.
2. Click the custom form in the list that you want to export.

To export more than one form at once, click the first form, hold down the Ctrl (Command) key on the keyboard and then click the other forms. This will highlight all of the forms you’ve selected within the list.

3. Choose File > Export Forms(s)... and choose the location on your computer where you want to save the exported form(s).

4. The forms are exported to the location you specified as .cfm files and are ready to be shared.

See "Importing custom forms" on page 10 for instructions on importing forms you have received from other users or TELUS Health.

Editing custom forms with the basic editor

You can create a new custom form only if you have purchased the separate licence and attended the custom form training course. For information about using the full custom form editor, see the PS
Suite Custom Forms Guide.

If you do not have this licence, you can still edit or duplicate an existing custom form, using the basic editor. You are limited to changing text fields, default values, and keywords. For example, you may want to create specific lab requisitions for prenatal or diabetes with the relevant tests already selected.

If a form was already used in one or more patient charts, deleting a field, or making it invisible, will hide any data that was previously added in that field for all patients using this form. Instead, duplicate the form, give it a different name, and then make your modifications to ensure that no unintended changes are made to existing patient charts.

Steps

1. Choose Settings > Edit Custom Forms.

   You can also open a custom form for editing using a form that is already inserted in a progress note; right-click (Ctrl+click) the form and choose Edit Form. When you save the form after making changes, new content appears on the form in the progress notes. Do not use this option if you do not want to make changes to an existing form, but only forms inserted in progress notes in the future.

2. Select the form, and choose Duplicate Form.

3. Type a new name for the form and click OK.

4. When prompted, select the basic editor.

   The form opens, with a list of keywords on the right side.

   When you click an element on the form, its properties are shown below the keyword list. This is where you make your changes.

5. To change the default selection of a checkbox, click the checkbox in the form, then select (or clear, as appropriate) the checkbox beside the Checked property.

6. To change the text shown, change the Text property.
7. If a field uses a keyword, as in the `currentDate.short` keyword used for `Date of Visit` above, double-click a keyword in the list to change. For example, double-click `Month DD, YYYY` to change the keyword to `currentDate.long`.

8. When you are finished, click the red X in the top right corner. You are prompted to save your changes.

**Toolbar custom forms**

Toolbar custom forms are specialized and short custom forms that appear and act as a quick menu bar in the Records window. They provide useful links and shortcuts to frequently accessed functionality and can save you time—with one click of the mouse, you can insert stamps, create a letter from a template, insert a custom form, create a lab requisition, open a handout, create a bill, and so on.

Toolbars are especially useful for specialists, who can customize condition-specific functionality.

When activated, a toolbar appears below the patient profile section of the patient’s record, below the REM field (or above the progress notes if your patient profile appear on the left). It is activated by creating a reminder that will trigger the toolbar to appear for all relevant patients (e.g., “age <=100”) or for a specific user (e.g., “user initials = JC”).

**Creating and designing toolbar custom forms**

For information about creating and designing toolbar custom forms, see “Designing toolbar custom forms” in the Custom Forms Guide.

**Activating toolbar custom forms with reminders**

Toolbars are designed to use the option within a reminder that links to a custom form. To activate a toolbar and have it displayed in a patient chart, you must create or edit a reminder to add conditions
that will trigger the display of the toolbar.

For example, you may want a certain toolbar to be activated only if a certain user is logged in (e.g., one for doctors and one for nurses), if the patient has a certain condition (e.g., a toolbar for only diabetes or hypertension patients), or a common toolbar to appear all the time for all users and patients.

Before you activate a toolbar, the toolbar custom form must already be imported in your PS Suite EMR (see “Importing custom forms” on page 10).

Steps

1. Create a new reminder (from the Records file, Settings > Edit Reminders).

2. Specify the reminder condition that will trigger the toolbar.

<table>
<thead>
<tr>
<th>Condition</th>
<th>Examples</th>
</tr>
</thead>
</table>
| Toolbar always appears for a specific user or for a specific role | - Current User’s Role is Nurse Practitioner  
- Current User’s Role is Doctor  
- Current Doctor Initials is JC |
| Toolbar appears if a patient has a certain condition | - CFP Prob Description Contains Problem, where Problem represents the condition |
| Toolbar to appear for all patients                    | - Age <= 110                                                             |

3. In the Show Custom Form or Stamp field, choose the toolbar custom form.
4. Save the reminder. The toolbar will now appear in patient charts that trigger the reminder.

Using toolbar custom forms

After a toolbar is activated (see "Activating toolbar custom forms with reminders" on page 14), it appears at the bottom of the CPP section of the patient’s record, below the REM field. To use a toolbar, simply click a link and the associated item will open.

You can hide toolbar custom forms independently of the patient profile. Choose View > Hide/Show Reminders Toolbar (Ctrl [Command] + Alt + W).

- Hide the profile and leave toolbars visible
- Hide both the profile and toolbars
- Show both the profile and toolbars
**Prescription commands in toolbars**

When a toolbar includes a prescription or treatment command, once the system enters the text in the medication name field, press the Tab key to move forward to the rest of the prescription fields. If you enter the exact name of an existing prescription favourite in the toolbar custom form, when you press the Tab key to move forward, all of the prescription fields are populated using data pulled from the prescription favourite.
Creating and designing custom forms

Custom forms are used for recreating paper-based forms. Custom forms are populated with data from PS Suite EMR, removing the drudgery of filling out forms manually.

If you have obtained the separate custom forms licence and attended the custom forms training course, you can create and design your own new custom forms using the advanced custom forms editor. You will be prompted for the licence key the first time that you create a custom form. If you do not have this licence key, contact the PS Suite EMR support team.

Several stamps, letters, and custom forms are provided with the system. Before creating a new custom form, check whether an existing stamp, letter, or custom form meets your requirements. Checking the existing options may save you time and reduce redundancy in the system.

Some forms may be protected by copyright. We recommend that you obtain permission from the copyright owner prior to implementing the form in your system.

Navigating the forms editor

You create custom forms by using the forms editor (Records file > Settings > Edit Custom Forms).
If you want to check the spelling of the contents of your form, choose **Edit > Check Spelling**. If there are any spelling mistakes, a window opens and the first mistake is highlighted. You can then choose to ignore the word, change it to a new suggested word, or add it to your personal dictionary. If there are further spelling mistakes, the next mistake is then highlighted.

**Drawing toolbar**

The drawing toolbar includes many tools, such as text and picture tools, for designing custom forms. It is located on the right side of the forms editor, and includes these tools.
<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Selection" /></td>
<td>The <strong>Selection</strong> tool selects one or more elements in the custom form. For more information, see &quot;Selecting elements&quot; on page 37.</td>
</tr>
<tr>
<td><img src="image" alt="Static Text" /></td>
<td>The <strong>Static Text</strong> tool inserts a single line of text in custom forms. Typically, this text is not editable when the custom form is inserted in a patient chart. For more information, see &quot;Adding a Static Text element&quot; on page 38.</td>
</tr>
<tr>
<td><img src="image" alt="Text Field" /></td>
<td>The <strong>Text Field</strong> tool inserts a single line box for the user to enter text in the custom form. For more information, see &quot;Adding a Text Field element&quot; on page 39.</td>
</tr>
<tr>
<td><img src="image" alt="TextArea" /></td>
<td>The <strong>TextArea</strong> tool inserts a multiple line box for the user to enter text in the custom form. For more information, see &quot;Adding a Text Area element&quot; on page 40.</td>
</tr>
<tr>
<td><img src="image" alt="Rectangle with square corners" /></td>
<td>The <strong>Rectangle with square corners</strong> tool inserts a rectangle (or square) in the custom form. For more information, see &quot;Adding a shape&quot; on page 44.</td>
</tr>
<tr>
<td><img src="image" alt="Rectangle with round corners" /></td>
<td>The <strong>Rectangle with round corners</strong> tool inserts a rectangle (or square) in the custom form. For more information, see &quot;Adding a shape&quot; on page 44.</td>
</tr>
<tr>
<td><img src="image" alt="Ellipsis" /></td>
<td>The <strong>Ellipsis</strong> tool inserts an ellipsis (or circle) in the custom form. For more information, see &quot;Adding a shape&quot; on page 44.</td>
</tr>
<tr>
<td><img src="image" alt="Line" /></td>
<td>The <strong>Line</strong> tool inserts a line in the custom form. For more information, see &quot;Adding a shape&quot; on page 44.</td>
</tr>
<tr>
<td><img src="image" alt="CheckBox" /></td>
<td>The <strong>CheckBox</strong> tool inserts a checkbox in the custom form for the user to select or clear an option in the custom form. For more information, see &quot;Adding a Check Box or Radio Button element&quot; on page 52.</td>
</tr>
<tr>
<td><img src="image" alt="Radio Button" /></td>
<td>The <strong>Radio Button</strong> tool inserts a radio button in the custom form for the user to select or clear an option in the custom form. For more information, see &quot;Adding a Check Box or Radio Button element&quot; on page 52.</td>
</tr>
<tr>
<td><img src="image" alt="ComboBox" /></td>
<td>The <strong>ComboBox</strong> tool inserts a combo box in the custom form for the user to select an option from a list in the custom form. For more information, see &quot;Adding a Combo Box element&quot; on page 53.</td>
</tr>
<tr>
<td><img src="image" alt="Button" /></td>
<td>The <strong>Button</strong> tool inserts a button in the custom form for the user to click in the custom form. For more information, see &quot;Adding a Button element&quot; on page 54.</td>
</tr>
<tr>
<td><img src="image" alt="Picture" /></td>
<td>The <strong>Picture</strong> tool inserts an image in the custom form. For more information, see &quot;Adding a Picture element&quot; on page 46.</td>
</tr>
<tr>
<td><img src="image" alt="Graph" /></td>
<td>The <strong>Graph</strong> tool inserts a graph in the custom form. For more information, see &quot;Adding a Graph element&quot; on page 49.</td>
</tr>
<tr>
<td><img src="image" alt="Flowsheet" /></td>
<td>The <strong>Flowsheet</strong> tool inserts a flowsheet in the custom form. For more information, see &quot;Adding a Flowsheet element&quot; on page 59.</td>
</tr>
<tr>
<td>Tool</td>
<td>Description</td>
</tr>
<tr>
<td>------------------</td>
<td>--------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Page Break</td>
<td>The Page Break tool inserts a page break in the custom form. For more information, see &quot;Inserting a Page Break element&quot; on page 58.</td>
</tr>
<tr>
<td>Signature</td>
<td>The Signature tool inserts a signature in the custom form. For more information, see &quot;Adding a Signature element&quot; on page 61.</td>
</tr>
</tbody>
</table>

### Properties pane

Every type of element available for custom forms has a set of properties. For example, the **Line** element includes such properties as its width, colour, and thickness.

When you add an element, default settings are used. You can change the properties to customize the element for your requirements.

Properties for an element are available when the element is selected in the custom form. Properties are displayed in the **Properties** pane.

#### Name property

Every element has a **Name** property. This name is assigned by you to uniquely identify the element. The name should meaningfully identify the element and should not be changed once the form has
been used in a patient’s chart.

We recommend naming elements to allow for searching within specific fields in the custom form. However, you are not required to name elements.

You can provide the name for a selected element by typing the name in the Name box in the Properties pane.

Design best practices

Creating a custom form involves these design tasks:

1. Specify the form’s general properties, such as its name (see "Specifying properties for a custom form" on the next page).

2. Define the form’s page layout (see "Defining the page layout" on page 25).

3. Choose a method to build your form:
   - From scratch, without an image or PDF of an existing form (see "Building a custom form from scratch" on page 27).
   - From an existing image (see "Building a custom form from an image" on page 28).
   - From an existing PDF (see "Building a custom form from a PDF" on page 32).

To help you decide which method to use, see "Choosing a method to build your form" on page 27.

4. Add items to your form, such as graphics, text, user interface controls, events, and so on (see "Adding elements to a custom form" on page 36).

5. Test your form to ensure that it functions as intended (see "Testing a custom form" on page 75).

Tips for measuring and placement

The unit of measurement for custom forms is “points”, where:

- 1 point = 0.35mm
- 72 points = 1 inch

To make reproducing existing forms easier, you may want to purchase a ruler that measures in points. These types of rulers are often available in art supply stores.

When placing elements in the form, you can drag them to the location in which you want them to appear. For more precise positioning, specify the location relative to the X- or Y-axis.
- The X-axis is the vertical length of the form. X is the distance from the top of the form.
- The Y-axis is the horizontal length of the form. Y is the distance from the left edge of the form.

For example, the top left corner of the form is X position 0 and Y position 0.

Specifying properties for a custom form

The first step when creating a custom form is to define the following properties:

- **Name.** Use a meaningful name to identify the purpose of the form, such as “New Patient History”.
- **Default view in patient charts.** When users insert a custom form in a patient chart, it is open to enable the user to complete it. You can set the custom form to collapse in patient charts when accessed in the future. Collapsing the form saves space in the patient chart, which minimizes the amount of scrolling required when working with the patient chart. You can expand the custom form at any time to view it.
- **Onscreen scale in patient charts.** This scale sets the size of the custom form when viewed in a patient chart. The smaller the value of the onscreen scale, the less space that the form uses when it is viewed in a patient’s chart. The value 1.17 is typically recommended to display the form at a smaller than actual size, without losing readability.

If you have taken the custom forms training course, but have never created a new custom form in your system, you will be prompted for the license key. If you do not have this licence key, contact the PS Suite EMR support team.

**Steps**

1. From the main toolbar, choose **Settings > Edit Custom Forms**.
2. Click **Create Custom Form**.
3. If you are prompted to enter a licence key, type it in the box provided and click **OK**.
4. Type a name for the form and click **OK**.

When creating forms on a live system, include “DO NOT USE” in the form name. Once the form is tested and is ready for use, rename the form and remove “DO NOT USE”.
5. Choose Custom Form > Collapse in Notes View By Default and verify that a check mark appears beside this option.
6. Choose Custom Form > Set Onscreen Scale.

7. Change the value to 1.17 and click OK.

8. In the forms editor, choose File > Save.

**Defining the page layout**

Several settings affect the page size of the form and how it prints. These settings include the:

- Height of the pages in the form and whether they need to adjust to accommodate content provided when the form is filled out
- Printer margins
You can change the page layout while you create and design the form. However, you may find that it’s convenient to check these settings before starting to work with the custom form, and then adjust as required. For example, if you add elements when designing the custom form, you may need to increase the page size.

Setting the page height

By default, custom forms have one page, with a height of 792 pixels. For information about measurements in pixels, see "Tips for measuring and placement" on page 22.

You may need to adjust the page height as you design the form. For example, you may need to add pages to accommodate the content that you need in the form. Similarly, you may want to decrease the height if there is unused space in the form. Regardless of the page height you set, printing the custom form prints each page on a standard letter paper size.

Each additional page in the form is set to a height of 742 pixels. For example, if you change the form to two pages, the height is set to 1534 pixels. The extra 50 pixels for the first page represents the space between the bottom margin and the bottom of the page. The top and bottom margins are identified by a blue line.

The Text Area element provides a property that allows the element size to adjust dynamically to fit the content being typed by the user. If this property is set for a Text Area element at the bottom of the form, ensure that the page height can also adjust dynamically. For information about this element, see "Text element properties" on page 41.

Steps

1. From the forms editor toolbar, choose Custom Form > Change Height.
2. From the Number of Pages box, select the number of pages for the form and click OK.
3. If the last element on the form is a Text Area element that uses the Grow with Text property, choose Custom Form > Change Height Dynamically.

You can also adjust the page size by dragging the page size icon in the bottom right corner of the page to the position you need.
Setting the printer margins

Depending on the page size and the printer you are using, you may need to adjust the printer margins when printing the form. In most cases, your printer will display a message if an issue needs to be resolved.

**Steps**

1. From the forms editor toolbar, choose **Custom Form > Set Margins**.
2. Type the value in pixels for the horizontal (side) margins and click **OK**.
3. Type the value in pixels for the top margin and click **OK**.
4. Type the value in pixels for the bottom margin and click **OK**.

Choosing a method to build your form

You must choose one of the following methods to build your form. These guidelines can help you to decide which method to use.

<table>
<thead>
<tr>
<th>Build from scratch</th>
<th>Build from image</th>
<th>Build from PDF</th>
</tr>
</thead>
<tbody>
<tr>
<td>You do not have a PDF or image of the form. The form will require changes on a regular basis, such as a form that contains procedures for patient visits. See &quot;Building a custom form from scratch&quot; below.</td>
<td>You have a scanned image (PNG, GIF, or JPG/JPEG) of a form, such as a copy of a hospital or requisition form. See &quot;Building a custom form from an image&quot; on the next page.</td>
<td>You have an original PDF of the form, which was created and saved with a PDF editor, such as a form directly from the government or hospital. You want a landscape-oriented form. Using an original PDF provides crisp and clean printed forms. See &quot;Building a custom form from a PDF&quot; on page 32</td>
</tr>
</tbody>
</table>

Building a custom form from scratch

If you are creating a custom form from scratch, you may want to add an outline, which provides a border to help distinguish the custom form from other information in a patient chart.

Remember to first specify the form properties (see "Specifying properties for a custom form" on page 23.)
Steps

1. From the drawing toolbar, select the Rectangle tool 🟤.

2. In the edit area, click and drag to create the border.

   For example, to create a border for a default page size, starting in the top left corner of the page, click the mouse and drag it to the bottom right corner of the page.

Building a custom form from an image

If you are creating a custom form based on an image of an existing form, import the image, customize its size (if necessary), and put it in the background of the custom form.

You can import images that are in these formats (in order of preference): PNG, GIF, or JPG/JPEG. Print the image at full page size to be sure it produces acceptable quality.

This section assumes that you have already saved the image to a file and that you have already specified form properties for a new custom form. For information, see "Specifying properties for a custom form" on page 23.

If you only want to use parts of the image, you can either edit the image in your graphic software or you can hide some parts of the image (see "Hiding parts of an image in a custom form" on page 31).

Remember to first specify the form properties (see "Specifying properties for a custom form" on page 23).

Steps

1. From the drawing toolbar, click the Picture tool 📸.

2. In the edit area, draw a rectangle to contain the image.

   Don’t worry about the size of the rectangle. You can adjust the size after adding the image.

3. Locate the image and click Choose.

4. If you need to adjust the image size to fit the page, in the Properties pane, in the Scale box, type the value that represents the new size of the image.

   For example, the value 1.0 represents the image at full size. To scale it to three-quarters of this size, type 0.75.

   If the Properties pane is not visible, click the image.
5. Drag a corner of the rectangle that contains the image to change its size, which affects how much of the image is displayed.
6. Repeat steps 4 and 5 until the image fits the page.

7. In the Properties pane, select the In Background checkbox to prevent further edits.

   If you need to change the image at a later time, remove the image and start over. From the forms editor toolbar, choose Edit > Clear Images in Background.

Finding images to use in custom forms

You can scan any image that you own and save it as a .PNG file to use as the basis for a custom form (see "Building a custom form from an image" on page 28). The internet is also a good source. If you use Google to search, filter your search results by "Images" and "Line drawing".

⚠️ Some images may be protected by copyright. We recommend that you obtain permission from the copyright owner prior to implementing the image in your custom forms.

Hiding parts of an image in a custom form

If you create a custom form that is based on an image, you can hide parts of the images so that they don’t appear in the form. You do this by adding a white shape on top of the parts of the image that you want to hide.

Steps

1. In the forms editor, use the shape tool to draw an outline around the area that you want to hide.
2. In the properties pane, change the Colour of the shape to white.
3. Select the Fill checkbox.
4. Select the Include in printout checkbox.
For example, in the following custom, the head portion of the image will appear hidden.

![Custom Form Image](image.png)

**Building a custom form from a PDF**

If you have an original PDF file of the form, which was created and saved with a PDF editor (such as a form directly from the government or hospital), use the PDF file as the basis for your custom form.

Custom forms created from an original PDF provide the added benefit of crisp and clean printed forms and the ability to have a form in landscape format (see "Creating a custom form in landscape format" on page 35).

Creating a custom form from a PDF involves the following tasks:

1. Start with an original PDF file that contains all of the pages that you want to include in the form and no extra pages.

   For convenience, the forms editor provides tools for splitting or joining PDF files so that they contain only the pages that you want to include in the custom form (see "Splitting or joining PDF pages" on the next page).

2. Create a PNG image file for each page of the PDF.
The forms editor and the patient chart use and display the PNG image on your screen. When printing, the system uses the PDF.

3. Import the PNG files for the PDF pages.

Remember to first specify the form properties (see "Specifying properties for a custom form" on page 23).

Splitting or joining PDF pages

The PDF that you use as the basis for your custom form must contain all of the pages that you want to include and no extra pages. For convenience, the forms editor provides tools for preparing a PDF with only the pages that you want to include in the custom form. These tools join pages in two PDFs to create one PDF, or split each page in a PDF into its own PDF. These tools are useful if you do not have third-party tools for working with PDFs.

Splitting PDF pages

If PDF file contains multiple pages and you want to create a separate custom form for each page, you must split the pages into separate PDF files.

The system creates the individual PDFs in the same folder as the original PDF. Individual PDFs use the same name as the original PDF, plus the suffix "p<n>" to indicate the page number. For example, “MyForm.pdf” containing three pages results in “MyFormp1.pdf”, “MyFormp2.pdf”, and “MyFormp3.pdf”.

Joining PDF pages

If you want to include pages that are in two separate PDFs into one single custom form, you must first join the pages and create one single PDF.

Steps

1. To split a PDF:
   - From the forms editor toolbar, choose File > Utilities > Split PDF File.
   - Locate the PDF and click Choose.

2. To join PDFs:
   - From the forms editor toolbar, choose File > Utilities > Join PDF File.
   - Locate the first PDF and click Choose.
   - Locate the second PDF and click Choose.
   - Type a name for the new PDF and click Save.
If you have additional PDFs that you want to include, repeat Steps 1 to 4 until all the PDFs are joined.

Creating PNG image files

Each page of the PDF must be a PNG image file before you can include it in the custom form. The forms editor and the patient chart use and display the PNG image on your screen. When printing, the system uses the PDF.

You create PNG image files for pages using third-party applications. The PNG image must be saved in the same physical size as the PDF. Do not resize the PNG file.

If you are using a Mac, you must have access to the Preview application.

If you are using Windows, you must have access to Acrobat Standard or Professional. You cannot convert PDF files to PNG image files using Acrobat Reader.

Steps for a Mac

1. In the Preview application, open the first PDF file.
2. Choose File > Save As.
3. Change the Format to PNG and click Save.
   - The system creates an image file in the same location as your PDF with the same name, but with no extension.
4. Repeat Steps 1 to 3 for each PDF to be imported into the custom form.
5. After saving all PDFs that you want to include in the custom form as PNG image files, close Preview.

Steps for Windows

6. In the Adobe Acrobat application, open the first PDF file.
7. Choose File > Save As > Image > PNG.
8. Click Settings.
9. Change the Resolution to 150 pixels/inch and click OK.
10. Click Save.
   - The system creates an image file in the same location as your PDF with the same name, but using the .png extension.
11. Repeat Steps 1 to 5 for each PDF to be imported into the custom form.
12. After saving all PDFs that you want to include in the custom form as PNG image files, close Adobe Acrobat.

Building the PDF custom form

You build the custom form using the PDF that includes all of the pages you want to include in the form and the PNG image files created from the PDF.

When building the custom form, you are prompted to provide a scale fraction. The system uses this value to position the PNG images relative to both the page size of the custom form and the original PDF.

If at a later date you no longer have access to the PDF that was used to create the form, you can export the PDF source data for the custom form to create a new PDF file. Choose File > Utilities > Export Source PDF.

Steps

1. From the forms editor toolbar, choose Custom Form > Build from PDF.
2. Locate the PDF and click Choose.
3. Type the number of pages this PDF contains and click OK.
4. Set the Scale Fraction to 0.48 and click OK.

If using Mac OS 10.4 or 10.5, set the Scale Fraction to 0.50.

5. When prompted, locate the first PNG file and click Choose.
6. When prompted, continue choosing each PNG file in the order you want them to appear in the custom form.
   The system prompts you for the number of pages you specified in step 3.
7. When you are notified that the PDF was successfully imported, click OK.

Creating a custom form in landscape format

You can create a custom form that appears and prints in landscape format.
Custom forms in landscape format must be built from a PDF, which is saved with a landscape orientation (see "Building the PDF custom form" on the previous page). PS Suite EMR uses the landscape page orientation of the PDF when printing the custom form.

Steps
1. Create your custom form as described in "Building a custom form from a PDF" on page 32.
2. From the Edit menu, choose Find and Select Items.
3. When prompted, choose Type and Picture. This selects the picture in the background of the custom form.
4. In the Properties pane, clear the In Background checkbox.
5. Invert the Width and Height of the image (or set to the selected number of points) or click the image itself and resize it manually by dragging on of the corners of the image until the image is sized correctly for landscape format.
6. In the Properties pane, select the In Background checkbox.
7. Choose File > Save.
8. Test printing the custom form to ensure that it prints in landscape format. From the forms editor toolbar, choose File > Test Print.

You can now design the custom form and it will print in landscape format. Ignore the right and bottom blue margins identified by a blue line.

Adding elements to a custom form

After you specify the custom form’s properties and choose a method to build it, you will want to continue designing it and add various elements. You can:

- Selecting elements to perform actions, such as copying or moving them
- Adding text elements
- Adding graphic elements
- Adding user interface controls (such as radio buttons) and related events
- Resizing element
- Aligning elements
- Defining page breaks
- Applying a tab order to selected elements
To help you find elements in your custom form, you can search for elements on the custom form.

Selecting elements

Before you can work with an element in the custom form, you must select it. For example, select an element to move it, change its properties, or delete it.

You can select more than one object at the same time to perform an action, such as copying or moving, on all selected objects.

Steps

1. In the drawing toolbar, click the Selection tool.
2. In the edit area, click the element you want to select.
   - To select multiple items, press the shift key and click on each one.
   - You can also select multiple objects by clicking and dragging around the elements.

Searching for elements

If your custom form includes many elements, you may find it convenient to search for elements that you want to work with. You can search for elements in a custom form by:

- Name or ID
- Property value (other than name or ID)
- Type

You can search only property values that are numeric.

If matching elements are found, they are selected.

Although you are not required to define a name property for every element, doing so gives you more options if you need to search for those elements at a later time.

Steps

1. From the forms editor toolbar, choose Edit > Find and Select Items.
2. Do one of the following:
   - If you want to search by name, click Name or ID. Type the name or ID and click OK.
If you want to search by a property other than name or ID, click Property Value. Type the name of the property (for example, X) and click OK. Type the value of the property (for example, 228) and click OK.

If you want to search by element type, click Type. Select the element type from the list (for example, a Picture element) and click OK.

Inserting text

There are three ways to add text to a form:

- Using a static text element to display single-line descriptions (such as a title for the form), EMR data populated using keywords, or hyperlinks
- Text fields for entering a fixed amount of information when using the form
- Text areas for entering free-form information when using the form, where the area expands to accommodate the amount of text entered

Adding a Static Text element

The Static Text element is useful for:

- Adding descriptive information to a custom form, such as a title for the form or a name for a field
- Displaying a hyperlink for a URL in a custom form. When the hyperlink is clicked, the web page for the URL displays in a separate browser window
- Populating the form with keyword data from the system, such as patient surname and first name, or current date.

Each Static Text element occupies a single line only. If you require a larger area of static text, use the Text Area element. For information, see "Adding a Text Area element" on page 40.

By default, a Static Text element is not editable once the custom form is inserted in a patient chart. However, you can change the properties of this element to make it editable.

Steps

1. In the drawing toolbar, click the Static Text tool.  
2. In the edit area, click the location where you want this element to start and drag to the location where you want the element to end.
   
   You can adjust the size of this element later.  
3. In the Properties pane, in the Name box, type a name for the element.
The Properties pane appears only when the element is selected.

4. In the Properties pane, do one of the following:
   - If you are adding text for display in the form, in the Text box, type the text.
   - If you are adding keywords, in the tree view, double-click on the keyword that you want to use to populate the field. For example, under the Demographics folder, double-click First Name.

5. If necessary, adjust the size of the Static Text element.

   If text in the element starts or ends with “…” , the text takes up more room than is available.

6. If you want to make this text editable when the custom form is inserted in the patient chart, in the Properties pane, select the Editable checkbox.

7. In the Properties pane, modify any other properties for this element.

   For information about other properties, see “Text element properties” on page 41.

Adding a Text Field element

The Text Field element is used for filling out information manually on the form in the patient chart. For example, you could use a Text Field element to enable a user to enter data during an interview with a patient or for data that is not stampable (such as “Surname”).

Each Text Field element occupies a single line only. If you require a larger area of static text, use the Text Area element. For information, see “Adding a Text Area element” on the next page.

Steps

1. In the drawing toolbar, click the Text Field tool.

2. In the edit area, click the location where you want this element to start and drag to the location where you want the element to end.

   You can adjust the size of this element later.

3. In the Properties pane, in the Name box, type a name for the element.

   The Properties pane appears only when the element is selected.

4. In the Properties pane, modify any other properties for this element.

   For information about other properties, see “Text element properties” on page 41.
Adding a Text Area element

The Text Area element is used for larger text areas, such as a medical history, accident description, or form instructions.

Text Area elements can be sized to fit the available area in both the X and Y directions, and therefore can occupy several lines of text. These elements are editable by default, but you can change the Editable property to make it static text. For example, you may want to do this if you have static text to display, but it requires more than the single line available for Static Text and Text Field elements.

Text Area elements can function like stamps. For information, see "Example: Creating a Text Area element that functions as a stamp" below.

Steps

1. In the drawing toolbar, click the Text Area tool.

2. In the edit area, click the location where you want this element to start and drag to the location where you want the element to end.

   You can adjust the size of this element later.

3. In the Properties pane, in the Name box, type a name for the element.

   The Properties pane appears only when the element is selected.

4. If you want to display text in the custom form, type the text manually in the field.

   Leave the field blank for the user to enter text.

5. If you typed text and you want to make this text uneditable when the custom form is inserted in the patient chart, in the Properties pane, select the Editable checkbox.

6. In the Properties pane, modify any other properties for this element.

   For information about other properties, see "Text element properties" on the next page.

Example: Creating a Text Area element that functions as a stamp

Although Text Area elements can be made stampable, it is unlikely that the EMR will have any stampable data relevant to these fields. However, Text Area elements can function like stamps. The following procedure provides an example.

Steps

1. Create a text area on your custom form.

2. In the Text property, type the following:
HT: (then 10 spaces) WT: (then 10 spaces) <<BMI>>

Copy <<BMI>> from an existing stamp and paste it into the Text property.

3. Save the form and test it in a chart as follows:

- Tab to HT: and type a height.
- Tab to WT: and type a weight.
- Tab to <<BMI>> and press Tab again.

The system calculates the BMI based on the specified height and weight.

Text element properties

The following table describes the properties that apply to Static Text, Text Field, and Text Area elements.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Id</td>
<td>This value is assigned by the system and cannot be changed.</td>
</tr>
<tr>
<td>Band Id</td>
<td>If the item is part of a collapsible section, this property automatically lists the ID of the collapsible section (see &quot;Making sections collapsible&quot; on page 70).</td>
</tr>
<tr>
<td>Name</td>
<td>A name that you assign to identify this element. The name should meaningfully identify the element. A field name should not be changed once the form has been used in a patient’s chart.</td>
</tr>
<tr>
<td>X</td>
<td>The X coordinate (distance from the left margin) in pixels. After dragging and dropping the element in the desired location, use the X coordinate for more precise alignment with other objects in the form.</td>
</tr>
<tr>
<td>Y</td>
<td>The Y coordinate (distance from the top margin) in pixels. After dragging and dropping the element in the desired location, use the Y coordinate for more precise alignment with other objects in the form.</td>
</tr>
<tr>
<td>Colour</td>
<td>The element’s colour. The default is black, which should be used for most forms.</td>
</tr>
<tr>
<td>Visible</td>
<td>Determines whether the element is visible on the custom form. This option is selected (representing “yes”) by default and in most cases should not be changed.</td>
</tr>
<tr>
<td>Opaque</td>
<td>Determines whether the element is opaque, covering anything behind it.</td>
</tr>
<tr>
<td>Event handlers</td>
<td>Defines what happens to this element when a predefined action occurs. For information, see &quot;Defining events&quot; on page 65.</td>
</tr>
<tr>
<td>Tooltip Text</td>
<td>Instructions or tips that appear when the user hovers the mouse over this element.</td>
</tr>
<tr>
<td>Property</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Section ID</strong></td>
<td>Defines a value that identifies this element as belonging to a group. All other elements in the group use the same value. This property is useful when searching and selecting elements by property. For information, see &quot;Searching for elements&quot; on page 37.</td>
</tr>
<tr>
<td><strong>Text</strong></td>
<td>The text that displays on the custom form. To use a keyword to automatically populate the text field, double-click a keyword in the tree view, including any Associated URL links.</td>
</tr>
<tr>
<td><strong>Font Name</strong></td>
<td>The text's font.</td>
</tr>
<tr>
<td><strong>Size</strong></td>
<td>The size of the font. The default is 9-point; select a larger or smaller size if required to fit the available space.</td>
</tr>
<tr>
<td><strong>Style</strong></td>
<td>The font style. Plain, bold or italic. Plain is generally recommended.</td>
</tr>
<tr>
<td><strong>Width</strong></td>
<td>Specifies the width (or height) of the element in pixels. Do not use negative values. The print function may interpret the page boundaries differently from those intended and print a blank page.</td>
</tr>
<tr>
<td><strong>Height</strong> (only for text area elements)</td>
<td></td>
</tr>
<tr>
<td><strong>Required</strong></td>
<td>Identifies with a red asterisk any mandatory fields that users are required to fill in (see &quot;Making fields mandatory&quot; on page 69).</td>
</tr>
<tr>
<td><strong>Show Edit Text Border</strong></td>
<td>Determines whether a border encloses the field.</td>
</tr>
<tr>
<td><strong>Include in Printout</strong></td>
<td>Determines whether the element is included when the form is printed. If this property is not selected, the element appears in the patient chart, but not in any printouts.</td>
</tr>
<tr>
<td><strong>Compact Stamp Text</strong></td>
<td>Adjusts any stamp text in this field to take up a minimal amount of space. For example, when stamping in the medication list for a patient, medications will be listed on a single line, rather than listing one medication per line.</td>
</tr>
<tr>
<td><strong>Graph As</strong></td>
<td>If this form will contain data that you want to be included when graphing EMR data, enter the value to be graphed (such as &quot;wt:&quot;, &quot;bp:&quot;, etc.) in the Graph As property.</td>
</tr>
<tr>
<td><strong>Graph Date Field Id</strong> (only for Text Field and Text Area elements)</td>
<td>The Graph Date Field Id determines the date that is associated with the graph value. To use the date of the progress note that the custom form is in, leave this field blank. To use a different date, create another Text Field element on the form where the user can enter a date, and be sure to enter a Name for the field. Then enter that field name in the Graph Date Field ID in the first Text Field element (the one that contains the graphable data and the Graph As field).</td>
</tr>
<tr>
<td><strong>Resource Name</strong></td>
<td>A placeholder to store values associated with the element when coding JavaScript. This property is not used unless you are using JavaScript.</td>
</tr>
<tr>
<td>Property</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Tab Order</td>
<td>The order in which the element will be activated when tabbing through all elements on the form. The order should correspond to the position rank in the form (top to bottom, left to right) in order for the tab function to work properly. You can set tab order for multiple elements at once. For information, see &quot;Applying tab order to multiple elements&quot; on page 65.</td>
</tr>
<tr>
<td>Justification</td>
<td>Determines whether the element is aligned left, centre, or right.</td>
</tr>
<tr>
<td>Editable</td>
<td>Determines whether users can overwrite any of the text in the custom form. For example, making static text editable means that users can change it.</td>
</tr>
<tr>
<td>Grow With Text</td>
<td>Determines whether the field will grow to accommodate the text typed by the user. Use this only if the Text Area element is the last object on the form; otherwise, it may cause overlap of other objects. Do not use this option for large amounts of data, as it may make text unreadable.</td>
</tr>
<tr>
<td></td>
<td><strong>Tips</strong></td>
</tr>
<tr>
<td></td>
<td>- For Text Area elements that grow, you should also choose Custom Form &gt; Change Height Dynamically so that the form can grow as well, and print additional pages if required.</td>
</tr>
<tr>
<td></td>
<td>- To prevent the growing text area from overlapping other elements in the form, add a horizontal white line below each text area. This will push other elements down as the text area grows.</td>
</tr>
<tr>
<td>Associated URL</td>
<td>Optionally, include a URL (such as to reference an external source). This URL will be a live link when the custom form is inserted into a note.</td>
</tr>
<tr>
<td>Max Length</td>
<td>The maximum number of characters that can be entered in this field. Leave the default 0 to indicate no limit (user can continue typing past the field boundary).</td>
</tr>
<tr>
<td>Link Click To</td>
<td>Specifies the name of a Check Box element that will be selected when this text element is clicked.</td>
</tr>
<tr>
<td>Property</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Click Event</strong>&lt;br&gt;(only Static Text and Text Field elements)</td>
<td>Specifies a name for the action that this element will trigger. For information, see &quot;Defining events&quot; on page 65.</td>
</tr>
<tr>
<td><strong>Format As</strong>&lt;br&gt;(only Static Text and Text Field elements)</td>
<td>Determines the format of the data. When specified, users must enter data using the required format, which appears as “masked text” in light grey colour (such as YYYY-MM-DD, ###-###-####). When you apply a date format, users can right-click {control-click} the date field or press Ctrl+spacebar to display a calendar to facilitate picking a date. If a user enters an incorrect format, a pop-up balloon indicates the required format. You can also pair this property with a validation button that uses the Id “validateForm”. When users click the validation button, a message pops up if they entered an incorrect text format. For more information, see &quot;Making fields mandatory&quot; on page 69.</td>
</tr>
</tbody>
</table>

**Adding a shape**

Shapes are primarily used when creating a form from scratch. You can add rectangles (with either square or rounded corners), ellipses (or circles), and lines.

**Steps**

1. In the drawing toolbar, click the shape tool.

2. In the edit area, click the location where you want this element to start and drag to the location where you want the element to end.

   You can adjust the size of this element later.

3. In the **Properties** pane, in the **Name** box, type a name for the element.

   The **Properties** pane appears only when the element is selected.
4. In the **Properties** pane, modify any other properties for this element.

**Shape element properties**

The following table describes the properties that apply to shape elements.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Id</td>
<td>This value is assigned by the system and cannot be changed.</td>
</tr>
<tr>
<td>Name</td>
<td>Displays a name that you assign to identify this element. The name should meaningfully identify the element. A field name should not be changed once the form has been used in a patient’s chart.</td>
</tr>
<tr>
<td>X</td>
<td>Identifies the X coordinate in pixels. After dragging and dropping the element in the desired location, use the X coordinate for more precise alignment with other objects in the form.</td>
</tr>
<tr>
<td>Y</td>
<td>Identifies the Y coordinate in pixels. After dragging and dropping the element in the desired location, use the Y coordinate for more precise alignment with other objects in the form.</td>
</tr>
<tr>
<td>Colour</td>
<td>Specifies the element colour. The default is black, which should be used for most forms.</td>
</tr>
<tr>
<td>Visible</td>
<td>Determines whether the element is visible on the custom form. This option is selected (representing “yes”) by default and should not be changed.</td>
</tr>
<tr>
<td>Opaque</td>
<td>Determines whether the element is opaque, covering anything behind it.</td>
</tr>
<tr>
<td>Event Handlers</td>
<td>Defines what happens to this element when a predefined action occurs. For information, see “Defining events” on page 65.</td>
</tr>
<tr>
<td>Tooltip Text</td>
<td>Specifies any instructions or tips that will appear when the user clicks on this element.</td>
</tr>
<tr>
<td>Section ID</td>
<td>Defines a value that identifies this element as belonging to a group. All other elements in the group use the same value. This property is useful when searching and selecting elements by property. For information, see “Searching for elements” on page 37.</td>
</tr>
<tr>
<td>Width Height</td>
<td>Specifies the width or height of the element in pixels. Do not use negative values; the print function may interpret the page boundaries differently from those intended and print a blank page.</td>
</tr>
<tr>
<td></td>
<td>To ensure that a horizontal line is completely straight, set the <strong>Height</strong> to 0. Similarly, for a vertical line set the <strong>Width</strong> to 0.</td>
</tr>
<tr>
<td></td>
<td><strong>Tip:</strong> There are several ways to resize elements. For other options, see &quot;Resizing individual elements&quot; on page 63.</td>
</tr>
<tr>
<td>Fill</td>
<td><em>Rectangle and Ellipsis only</em> Determines whether the element is filled with the colour defined by the Colour property.</td>
</tr>
<tr>
<td>Property</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Round Corners</td>
<td><em>Rectangle only</em> Determines whether the corners of a rectangle are rounded or squared.</td>
</tr>
<tr>
<td>Thickness</td>
<td><em>Rectangle and Line only</em> Determines the thickness of the lines in pixels.</td>
</tr>
<tr>
<td>Include in Printout</td>
<td><em>Rectangle and Line only</em> Determines whether the element is displayed when the form is printed. If this property is not selected, the element appears in the patient chart, but not in any printouts.</td>
</tr>
</tbody>
</table>

**Adding a Picture element**

The **Picture** element adds images to your custom form, such as logos and letterheads.

Supported image formats, in order of preference, include: PNG, GIF, or JPG/JPEG. Print the image at full page size to be sure it produces acceptable quality.

**Steps**

1. In the toolbar, click the **Picture** tool.

2. In the edit area, click the location where you want this element to start and drag to the location where you want the element to end.

   You can adjust the size of this element later.

3. Locate the image and click **Choose**.

4. If you need to adjust the image size, in the **Properties** pane, in the **Scale** box, type the value that represents the new size of the image.

   For example, the value **1.0** represents the image at full size. To scale it to half of this size, type **0.5**.

   If the **Properties** pane is not visible, click the image.
5. Drag a corner of the rectangle that contains the image to change how much of the image is displayed.

6. Repeat steps 5 and 6 until the image is displayed the way that you want.

7. In the Properties pane, in the Name box, type a name for the element. The Properties pane appears only when the element is selected.

8. If you don’t want the user to make changes to this image in the custom form, in the Properties pane, select the In Background checkbox.

   If you need to change the image at a later time, remove the image and start over. From the forms editor toolbar, choose Edit > Clear Images in Background.

9. In the Properties pane, modify any other properties for this element.

**Picture Element properties**

The following table describes the properties that apply to Picture elements.
<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Id</td>
<td>This value is assigned by the system and cannot be changed.</td>
</tr>
<tr>
<td>Name</td>
<td>Displays a name that you assign to identify this element. The name should meaningfully identify the element. A field name should not be changed once the form has been used in a patient's chart. We recommend naming elements to allow for searching within specific fields in the custom form.</td>
</tr>
<tr>
<td>X</td>
<td>Identifies the X coordinate in pixels. After dragging and dropping the element in the desired location, use the X coordinate for more precise alignment with other objects in the form.</td>
</tr>
<tr>
<td>Y</td>
<td>Identifies the Y coordinate in pixels. After dragging and dropping the element in the desired location, use the Y coordinate for more precise alignment with other objects in the form.</td>
</tr>
<tr>
<td>Colour</td>
<td>Specifies the element colour applied to the image boundaries and background.</td>
</tr>
<tr>
<td>Visible</td>
<td>Determines whether the element is visible on the custom form. This option is selected (representing “yes”) by default and should not be changed.</td>
</tr>
<tr>
<td>Opaque</td>
<td>Determines whether the element is opaque, covering anything behind it.</td>
</tr>
<tr>
<td>Event Handlers</td>
<td>Defines what happens to this element when a predefined action occurs. For information, see &quot;Defining events&quot; on page 65.</td>
</tr>
<tr>
<td>Tooltip Text</td>
<td>Specifies any instructions or tips that will appear when the user clicks on this element.</td>
</tr>
<tr>
<td>Section ID</td>
<td>Defines a value that identifies this element as belonging to a group. All other elements in the group use the same value. This property is useful when searching and selecting elements by property. For information, see &quot;Searching for elements&quot; on page 37.</td>
</tr>
<tr>
<td>Width</td>
<td>Specifies the width or height of the element in pixels. Do not use negative values. The print function may interpret the page boundaries differently from those intended and print a blank page.</td>
</tr>
<tr>
<td>Height</td>
<td>Tip: There are several ways to resize elements. For other options, see &quot;Resizing individual elements&quot; on page 63.</td>
</tr>
<tr>
<td>Drawable</td>
<td>Enables the user to use the sketching tools in the chart to draw on this picture. If the image has been place In Background, the sketching tools are not available.</td>
</tr>
<tr>
<td>Picture</td>
<td>Identifies the filename of the image that was imported.</td>
</tr>
<tr>
<td>Property</td>
<td>Description</td>
</tr>
<tr>
<td>----------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Scale</td>
<td>Specifies a scaling factor for the image. Use a lower value to shrink the picture or a higher value to increase the image. The default value of 1.0 represents 100%; 0.5 represents 50%. Note: The maximum useful size is determined by the resolution of the original image.</td>
</tr>
<tr>
<td>In Background</td>
<td>Places the image in the background, making it uneditable. Tip: To make changes to an image in the background, choose Edit &gt; Clear Images in Background, and then reimport the image.</td>
</tr>
<tr>
<td>Include In Printout</td>
<td>Determines whether the element is displayed when the form is printed. If this property is not selected, the element appears in the patient chart, but not in any printouts.</td>
</tr>
</tbody>
</table>

Adding a **Graph** element

Use the **Graph** element to display data graphically against time (represented by the X-axis). For example, you can graph the weight and compare it to a standard growth chart.

Graphs do not label the values you are graphing, nor do they display the start and ending values of the X- and Y-axes. You can instead display these values by using **Static Text** elements after you configured the graph.

**Steps**

1. Optionally, if you want to use an image (such as a standard growth chart) as the background of your graph, add the image in the background of your custom form.

2. In the drawing toolbar, click the **Graph** tool.

3. In the edit area, click the location where you want this element to start and drag to the location where you want the element to end.

   You can adjust the size of this element later.

4. Add a data source:
   - In the **Properties** pane, in the **Data Source** property, choose **Add**.
   - In the **Add Field** window, select the data type from the first column, then the data source from the second column.

   For example, select **Immunizations** from the first column and **Measles** from the second column.
You can add only one data source per graph. To show more than one data source, add another graph on top of the first graph, using the same X- and Y-axes values and positioning.

5. In the Properties pane, in the Name box, type a name for the element.

6. To determine the starting point for time on the X-axis (horizontal values), specify a Fix Dates Relative To.

7. To determine the number of days that your graph starts and ends on, relative to the date that you chose in the previous step, specify the Start Offset in Days and End Offset in Days.

8. Specify the Minimum Y Value and Maximum Y Value (vertical values).

9. In the Properties pane, modify any other properties for this element.

**Graph element properties**

The following table describes the properties that apply to Graph elements.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Id</td>
<td>This value is assigned by the system and cannot be changed.</td>
</tr>
</tbody>
</table>
| Name              | Displays a name that you assign to identify this element. The name should meaningfully identify the element. A field name should not be changed once the form has been used in a patient’s chart.  
We recommend naming elements to allow for searching within specific fields in the custom form. |
<p>| X                 | Identifies the X coordinate in pixels. After dragging and dropping the element in the desired location, use the X coordinate for more precise alignment with other objects in the form. |
| Y                 | Identifies the Y coordinate in pixels. After dragging and dropping the element in the desired location, use the Y coordinate for more precise alignment with other objects in the form. |
| Colour            | Specifies the element colour used for the graphing line.                                                                                     |
| Visible           | Determines whether the element is visible on the custom form. This option is selected (representing “yes”) by default and should not be changed. |
| Opaque            | Determines whether the element is opaque, covering anything behind it.                                                                        |
| Event Handlers    | Defines what happens to this element when a predefined action occurs. For information, see “Defining events” on page 65.                           |</p>
<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tooltip Text</td>
<td>Specifies any instructions or tips that will appear when the user clicks on this element.</td>
</tr>
<tr>
<td>Section ID</td>
<td>Defines a value that identifies this element as belonging to a group. All other elements in the group use the same value. This property is useful when searching and selecting elements by property. For information, see &quot;Searching for elements&quot; on page 37.</td>
</tr>
</tbody>
</table>
| Width Height | Specifies the width or height of the element in pixels. Do not use negative values; the print function may interpret the page boundaries differently from those intended and print a blank page.  
   **Tip:** There are several ways to resize elements. For other options, see "Resizing individual elements" on page 63. |
<p>| Data Source  | Contains the source of data from the EMR. Click in the property field to add or clear the data source.                                                                                                        |
| Show Border  | Select if you want a border around the graph.                                                                                                                                                    |
| Top Inset    | Adjusts the X and Y offset location of the graph. For example, a value of 5 shifts the graph 5 pixels down. This property is useful if you are also using a border.                                                 |
| Show Axes    | Determines whether the graph axes are displayed.                                                                                                                                                        |
| Show Normal Range | Determines whether normal value range is displayed.                                                                                                                      |
| Show Normal Axis Values | Determines whether normal axis values are displayed.                                                                                                                        |
| Show Percentiles | Specifies whether the percentile range is displayed.                                                                                                                  |
| Reference Date | Determines the starting point for time on the X-axis (for example, birthdate, today, date of last Pap, etc.).                                                      |</p>
<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start Offset in Days</td>
<td>Adjusts the start and end dates. Enter a positive or negative number. These values are added to (or subtracted from) the Reference Date to determine the start and end dates for the data display.</td>
</tr>
<tr>
<td>End Offset in Days</td>
<td></td>
</tr>
<tr>
<td>Minimum Y Value</td>
<td>Adjust the start and end points on the Y-axis. Depending on what you are graphing, enter values that will display the graph most effectively for the user.</td>
</tr>
<tr>
<td>Maximum Y Value</td>
<td></td>
</tr>
</tbody>
</table>

Adding a user interface element

User interface elements let the user select options and make choices in the custom form. For example, you can include a checkbox that the user selects to indicate that a particular question was asked or procedure completed. You can use a combo box to list options, from which the user selects the most appropriate.

The following user interface elements are available:

- Check Box
- Radio buttons
- Combo box
- Button

Adding a Check Box or Radio Button element

Use Check Box and Radio Button elements to present options from which the user can select. Generally accepted user interface practices recommend that you use:

- Radio Button elements when you want the user to choose only one option in a group. For example, you may want to list referral options and let the user choose the appropriate one for this patient.
- Check Box elements when you want to enable the user to choose multiple options in a group. For example, you may want to list several symptoms and let the user choose all that apply to the patient.
If you are creating a form from scratch, it’s a good idea to follow these standards. However, because you may base this custom form on an existing one that does not follow these standards, both elements work the same way in the forms editor.

If you find that a checkbox or radio button is not selectable in the patient chart, open the form in the forms editor and check to see if another element is overlapping the Check Box or Radio Button element.

Steps

1. In the drawing toolbar, click the Check Box or Radio Button tool.
2. In the edit area, click the location where you want this element to start and drag to the location where you want the element to end.

You can adjust the size of this element later.

If you want to include a text label, draw the border past the boundary of the Check Box or Radio Button element.

3. In the Properties pane, in the Name box, type a name for the element.

The Properties pane appears only when the element is selected.

4. In the Properties pane, modify any other properties for this element.

For information about other properties, see "User interface element properties" on the next page.

Adding a Combo Box element

A Combo Box element enables the user to select from a drop-down list of available options. For example, you may want to provide a list of hospital locations, from which the user can select one.

Steps

1. In the drawing toolbar, click the Combo Box tool.
2. In the edit area, click the location where you want this element to start and drag to the location where you want the element to end.

You can adjust the size of this element later.

3. In the Properties pane, in the Name box, type a name for the element.
The Properties pane appears only when the element is selected.

4. In the Properties pane, in the Items box, choose Add Batch.

5. Type each list item on a separate line and click OK.

6. In the Properties pane, modify any other properties for this element.

For information about other properties, see "User interface element properties" below.

**Adding a Button element**

Button elements are used to launch specific actions. For example, you can provide a button that, when clicked, automatically selects a series of checkboxes in the form.

**Steps**

1. In the drawing toolbar, click the Button tool.

2. In the edit area, click the location where you want this element to start and drag to the location where you want the element to end.

   You can adjust the size of this element later.

3. In the Properties pane, in the Name box, type a name for the element.

   The Properties pane appears only when the element is selected.

4. In the Text box, type a label for this button.

5. In the Event Triggered box, type a name for the action that selecting this button will trigger.

   Remember to define the event that occurs. For information, see "Defining events" on page 65.

6. In the Properties pane, modify any other properties for this element.

   For information about other properties, see "User interface element properties" below.

**User interface element properties**

The following table describes the properties that apply to Check Box, Radio Button, Combo Box, or Button elements.
<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Id</td>
<td>This value is assigned by the system and cannot be changed.</td>
</tr>
<tr>
<td>Name</td>
<td>Displays a name that you assign to identify this element. The name should meaningfully identify the element. A field name should not be changed once the form has been used in a patient’s chart. We recommend naming elements to allow for searching within specific fields in the custom form.</td>
</tr>
<tr>
<td>X</td>
<td>Identifies the X coordinate in pixels. After dragging and dropping the element in the desired location, use the X coordinate for more precise alignment with other objects in the form.</td>
</tr>
<tr>
<td>Y</td>
<td>Identifies the Y coordinate in pixels. After dragging and dropping the element in the desired location, use the Y coordinate for more precise alignment with other objects in the form.</td>
</tr>
<tr>
<td>Colour</td>
<td>Specifies the element colour. The default is black, which should be used for most forms.</td>
</tr>
<tr>
<td>Visible</td>
<td>Determines whether the element is visible on the custom form. This option is selected (representing “yes”) by default and should not be changed.</td>
</tr>
<tr>
<td>Opaque</td>
<td>Determines whether the element is opaque, covering anything behind it.</td>
</tr>
<tr>
<td>Event Handlers</td>
<td>Defines what happens to this element when a predefined action occurs. For information, see &quot;Defining events&quot; on page 65.</td>
</tr>
<tr>
<td>Tooltip Text</td>
<td>Specifies any instructions or tips that will appear when the user clicks on this element.</td>
</tr>
<tr>
<td>Section ID</td>
<td>Defines a value that identifies this element as belonging to a group. All other elements in the group use the same value. This property is useful when searching and selecting elements by property. For information, see &quot;Searching for elements&quot; on page 37.</td>
</tr>
<tr>
<td>Text</td>
<td>&lt;CheckBox and Radio Button elements&gt; Leave this property blank. It will be populated from within the progress note. &lt;ComboBox element&gt; If the text is to be selected from a list, leave this property blank. &lt;Button element&gt; The label to appear on the button.</td>
</tr>
<tr>
<td>Font Name</td>
<td>&lt;CheckBox, Radio Button, Combo Box elements&gt; Identifies the name of the font used to display the text.</td>
</tr>
<tr>
<td>Size</td>
<td>&lt;CheckBox, Radio Button, and Combo Box elements&gt; Identifies the size of the font used to display the text. The default is 9-point; select a larger or smaller size if required to fit the available space.</td>
</tr>
<tr>
<td>Text Size</td>
<td>&lt;Button element&gt; Identifies the size of the font used to display the text. The default is 9-point; select a larger or smaller size if required to fit the available space.</td>
</tr>
<tr>
<td>Property</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Style</strong></td>
<td><code>&lt;CheckBox, Radio Button, Combo Box elements&gt;</code> Identifies the style of the font used to display the text: Plain, <strong>bold</strong> or <strong>italic</strong>. Plain is generally recommended.</td>
</tr>
</tbody>
</table>
| **Width**                | Specifies the width of the element in pixels. Do not use negative values; the print function may interpret the page boundaries differently from those intended and print a blank page.  
**Tip:** Set the width to be as wide as the label, so that when the user clicks anywhere in the width, it turns on or off.  
**Note:** There are several ways to resize elements. For other options, see "Resizing individual elements" on page 63. |
| **Show Edit Text Border**| `<CheckBox, Radio Button, Combo Box elements>` Determines whether a border encloses the field. This option makes these elements easier for the user to see. |
| **Include in Printout**  | `<CheckBox, Radio Button, Combo Box elements>` Determines whether the element is displayed when the form is printed. If this property is not selected, the element appears in the patient chart, but not in any printouts. |
| **Graph As Graph Date Field ID** | `<CheckBox, Radio Button, Combo Box elements>` If this field will contain data that you want to be included when graphing EMR data, enter the value to be graphed (such as “wt:”, “bp:”, etc.) in the **Graph As** property.  
The **Graph Date Field ID** determines the date that is associated with the value in the graph. To use the date of the progress note that the custom form is in, leave this field blank. If you want to use a different date, create another **Text Field** element on the form, where the user can enter a date, and be sure to enter a Name for the field. Then enter that field name in the **Graph Date Field ID** in the first **Text Field** element (the one that contains the graphable data and the **Graph As** field). |
| **Resource Name**        | `<CheckBox, Radio Button, Combo Box elements>` A placeholder to store values associated with the element when coding JavaScript. This property is not used unless you are using JavaScript. |
| **Tab Order**            | Sets the order in which the element will be activated when tabbing through all elements on the form. The order should correspond to the position rank in the form (top to bottom, left to right) in order for the tab function to work properly.  
**Note:** **CheckBox** or **Radio Button** elements cannot be the starting point for **Tab Order**. If one of these elements is the lead object in the **Tab Order**, the system puts the focus on the first **Text Field** or **Text Area** element.  
**Tip:** You can set tab order for multiple elements at once. For information, see "Applying tab order to multiple elements" on page 65. |
<p>| <strong>Radio Button</strong>         | <code>&lt;CheckBox and Radio Button elements&gt;</code> Toggles the element between a <strong>CheckBox</strong> or a <strong>Radio Button</strong> element. |</p>
<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Checked</td>
<td><code>&lt;Check Box and Radio Button elements&gt;</code> Sets the default state of this Check Box or a Radio Button element as selected or not. This feature could be useful if a form requests checking off whether it was filled in by a physician or another healthcare professional; if the user of the custom form is a physician, it allows; the form to always have this Check Box or a Radio Button element selected.</td>
</tr>
<tr>
<td>Diameter</td>
<td><code>&lt;Check Box and Radio Button elements&gt;</code> Specifies the diameter of the Check Box or a Radio Button element in pixels.</td>
</tr>
<tr>
<td>Keyword for Selection</td>
<td><code>&lt;Check Box and Radio Button elements&gt;</code> Groups Check Box or a Radio Button elements such that the user can select only one at a time. For example, if one checkbox indicates “yes” and another checkbox specifies “no”, you may want to ensure that the user can select only one checkbox.</td>
</tr>
<tr>
<td>Items</td>
<td><code>&lt;Combo Box element&gt;</code> Contains the list items, separated by semicolons. Click in the property field and choose Add to add a single item, or Add Batch to add multiple items, or Clear to remove all list items. To change a list item, click in the property field and choose the list item, then make your changes.</td>
</tr>
<tr>
<td>Event Triggered</td>
<td>Specifies a name for the action that this element will trigger. For information, see &quot;Defining events&quot; on page 65.</td>
</tr>
<tr>
<td>Cycle State With Click</td>
<td><code>&lt;Combo Box element&gt;</code> Displays the options one at a time, rather than as a drop-down-list. A different option is displayed each time the user clicks the element.</td>
</tr>
<tr>
<td>Custom Height</td>
<td><code>&lt;Check Box, Radio Button, Combo Box elements&gt;</code> Enables you to adjust how much of the entire height (in pixels) of the Check Box or a Radio Button element actually displays. Use this option only when designing a form from scratch. Generally, the custom height should be about 25% bigger than the font size. For example, if the font size is 10, the custom height should be 13. If the bottom of the element is clipped, increase the custom height.</td>
</tr>
<tr>
<td>Toggle Group Name</td>
<td><code>&lt;Check Box and Radio Button elements&gt;</code> Assign a group name to group Check Box or a Radio Button elements of the same nature (e.g. Patient Gender could be a group name assigned to the M and F checkboxes) and make them mutually exclusive. The user will be able to choose only one option from the group.</td>
</tr>
<tr>
<td>Draw the Border</td>
<td><code>&lt;Check Box and Radio Button elements&gt;</code> Draws a border around the element. If you are designing the form from an image or PDF, turn this option off. If designing from scratch, turn it on.</td>
</tr>
<tr>
<td>Stop when Tabbing</td>
<td><code>&lt;Check Box and Radio Button elements&gt;</code> Enables users to tab to this element when tabbing from field to field. If Tab Order is set, this option is selected automatically.</td>
</tr>
<tr>
<td>Focusable</td>
<td><code>&lt;Button element&gt;</code> Enables user to tab to this button when tabbing from field to field. The default is off.</td>
</tr>
</tbody>
</table>
Inserting a **Page Break** element

For custom forms consisting of more than one page, you set the location for page breaks when the form is printed.

**Steps**

1. In the drawing toolbar, click the **Page Break** tool.
2. In the edit area, click the location where you want the page break to occur.
   
   You can adjust the location of this element later.
3. In the **Properties** pane, in the **Name** box, type a name for the element.
   
   The **Properties** pane appears only when the element is selected.
4. In the **Properties** pane, modify any other properties for this element.

**Page Break element properties**

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Id</strong></td>
<td>This value is assigned by the system and cannot be changed.</td>
</tr>
<tr>
<td><strong>Name</strong></td>
<td>Displays a name that you assign to identify this element. The name should meaningfully identify the element. A field name should not be changed once the form has been used in a patient’s chart.</td>
</tr>
<tr>
<td><strong>X</strong></td>
<td>Identifies the X coordinate in pixels. After dragging and dropping the element in the desired location, use the X coordinate for more precise alignment with other objects in the form.</td>
</tr>
<tr>
<td><strong>Y</strong></td>
<td>Identifies the Y coordinate in pixels. After dragging and dropping the element in the desired location, use the Y coordinate for more precise alignment with other objects in the form.</td>
</tr>
<tr>
<td><strong>Colour</strong></td>
<td>Specifies the element colour. The default is blue to distinguish it from other elements on the form, which default to the colour black.</td>
</tr>
<tr>
<td><strong>Visible</strong></td>
<td>Determines whether the element is visible on the custom form. This option is selected (representing “yes”) by default and should not be changed.</td>
</tr>
<tr>
<td><strong>Opaque</strong></td>
<td>Determines whether the element is opaque, covering anything behind it.</td>
</tr>
<tr>
<td><strong>Event Handlers</strong></td>
<td>Defines what happens to this element when a predefined action occurs. For information, see &quot;Defining events&quot; on page 65.</td>
</tr>
</tbody>
</table>
Adding a Flowsheet element

You can embed a Flowsheet element in a custom form. The flowsheet contents (criteria) are built within the forms editor using the Contents property. Any changes to values in the patient EMR are reflected automatically in the custom form’s flowsheet.

Because the flowsheet can be arbitrarily large when filled with patient data, scrollbars appear when the flowsheet contents exceed the defined width and height of the Flowsheet element. When printed, the most recent flowsheet contents are shown, with other data clipped off if necessary.

Steps

1. In the drawing toolbar, click the Flowsheet tool.

2. In the edit area, click the location where you want this element to start and drag to the location where you want the element to end.
   
   You can adjust the size of this element later.

3. In the Properties pane, in the Name box, type a name for the element.
   
   The Properties pane appears only when the element is selected.

4. In the Properties pane, click the Contents property and choose Add.

5. Select the category and specific item to be included in the flowsheet, and click OK.

6. Repeat steps 4 and 5 until you have added all of the fields you want to include.

7. In the Properties pane, modify any other properties for this element.

Flowsheet element properties

The following table describes the properties that apply to Flowsheet elements.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tooltip Text</td>
<td>Specifies any instructions or tips that will appear when the user clicks on this element.</td>
</tr>
<tr>
<td>Add Margin on Printout</td>
<td>Includes the margin when printing the form.</td>
</tr>
<tr>
<td>Property</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Id</td>
<td>This value is assigned by the system and cannot be changed.</td>
</tr>
<tr>
<td>Name</td>
<td>Displays a name that you assign to identify this element. The name should meaningfully identify the element. A field name should not be changed once the form has been used in a patient’s chart.</td>
</tr>
<tr>
<td>X</td>
<td>Identifies the X coordinate in pixels. After dragging and dropping the element in the desired location, use the X coordinate for more precise alignment with other objects in the form.</td>
</tr>
<tr>
<td>Y</td>
<td>Identifies the Y coordinate in pixels. After dragging and dropping the element in the desired location, use the Y coordinate for more precise alignment with other objects in the form.</td>
</tr>
<tr>
<td>Colour</td>
<td>Specifies the element colour. The default is black, which should be used for most forms.</td>
</tr>
<tr>
<td>Visible</td>
<td>Determines whether the element is visible on the custom form. This option is selected (representing “yes”) by default and should not be changed.</td>
</tr>
<tr>
<td>Opaque</td>
<td>Determines whether the element is opaque, covering anything behind it.</td>
</tr>
<tr>
<td>Event Handlers</td>
<td>Defines what happens to this element when a predefined action occurs. For information, see &quot;Defining events&quot; on page 65.</td>
</tr>
<tr>
<td>Tooltip Text</td>
<td>Specifies any instructions or tips that will appear when the user clicks on this element.</td>
</tr>
<tr>
<td>Section ID</td>
<td>Defines a value that identifies this element as belonging to a group. All other elements in the group use the same value. This property is useful when searching and selecting elements by property. For information, see &quot;Searching for elements&quot; on page 37.</td>
</tr>
<tr>
<td>Width Height</td>
<td>Specifies the width or height of the element in pixels. Do not use negative values. The print function may interpret the page boundaries differently from those intended and print a blank page.</td>
</tr>
</tbody>
</table>

There are several ways to resize elements. For other options, see "Resizing individual elements" on page 63.

Contents | Contains the source of data from the EMR. Click in the property field to add or clear the data source. |
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Font Size</td>
<td>Identifies the size of the font used to display the text. The default is 9-point; select a larger or smaller size if required to fit the available space.</td>
</tr>
<tr>
<td>Show Latest Value</td>
<td>Displays all values that match the field, sorted by date. If this property is selected, the latest value for each field is also shown at the top of the table.</td>
</tr>
<tr>
<td>Property</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Show Last Done</td>
<td>Displays all values that match the field, sorted by date. If this property is selected, the latest instance for each field is also shown at the top of the table.</td>
</tr>
<tr>
<td>Show Text of Reports</td>
<td>If you have included a report category, select this property to include the full text of the report.</td>
</tr>
<tr>
<td>Vertical Date Orientation</td>
<td>Select this property to view the fields down the side and the dates along the top.</td>
</tr>
<tr>
<td>Tab Order</td>
<td>Sets the order in which the element will be activated when tabbing through all elements on the form. The order should correspond to the position rank in the form (top to bottom, left to right) in order for the tab function to work properly. You can set tab order for multiple elements at once. For information, see &quot;Applying tab order to multiple elements&quot; on page 65.</td>
</tr>
</tbody>
</table>

Adding a **Signature** element

A **Signature** element provides a space in the custom form for a digital signature. When the custom form is inserted in a patient’s chart, a user with the **Doctor** or **Nurse Practitioner** role can double-click the box to display the digital signature, if an administrator defined one in the **Signature** preferences.

**Steps**

1. In the drawing toolbar, click the **Signature** tool.

2. In the edit area, click the location where you want this element to start and drag to the location where you want the element to end.

   You can adjust the size of this element later. The signature will always appear in the bottom centre of the box that you draw.

3. In the **Properties pane**, in the **Name** box, type a name for the element.

   The **Properties pane** appears only when the element is selected.

4. If you want to draw a border around the digital signature area, select the **Draw Box Border** checkbox.

   A border helps the user identify the area of the form to double-click to insert the signature.

5. In the **Properties pane**, modify any other properties for this element.
**Signature element properties**

The following table describes the properties that apply to Signature elements.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Id</td>
<td>This value is assigned by the system and cannot be changed.</td>
</tr>
<tr>
<td>Name</td>
<td>Displays a name that you assign to identify this element. The name should meaningfully identify the element. A field name should not be changed once the form has been used in a patient’s chart. We recommend naming elements to allow for searching within specific fields in the custom form.</td>
</tr>
<tr>
<td>X</td>
<td>Identifies the X coordinate in pixels. After dragging and dropping the element in the desired location, use the X coordinate for more precise alignment with other objects in the form.</td>
</tr>
<tr>
<td>Y</td>
<td>Identifies the Y coordinate in pixels. After dragging and dropping the element in the desired location, use the Y coordinate for more precise alignment with other objects in the form.</td>
</tr>
<tr>
<td>Colour</td>
<td>Specifies the element colour. The default is black, which should be used for most forms.</td>
</tr>
<tr>
<td>Visible</td>
<td>Determines whether the element is visible on the custom form. This option is selected (representing “yes”) by default and should not be changed.</td>
</tr>
<tr>
<td>Opaque</td>
<td>Determines whether the element is opaque, covering anything behind it.</td>
</tr>
<tr>
<td>Event Handlers</td>
<td>Defines what happens to this element when a predefined action occurs. For information, see &quot;Defining events&quot; on page 65.</td>
</tr>
<tr>
<td>Tooltip Text</td>
<td>Specifies any instructions or tips that will appear when the user clicks on this element.</td>
</tr>
<tr>
<td>Section ID</td>
<td>Defines a value that identifies this element as belonging to a group. All other elements in the group use the same value. This property is useful when searching and selecting elements by property. For information, see &quot;Searching for elements&quot; on page 37.</td>
</tr>
<tr>
<td>Width Height</td>
<td>Specifies the width or height of the element in pixels. Do not use negative values; the print function may interpret the page boundaries differently from those intended and print a blank page. Tip: There are several ways to resize elements. For other options, see &quot;Resizing individual elements&quot; on the next page.</td>
</tr>
<tr>
<td>Fill</td>
<td>If selected, the element is filled with the value of the Colour property.</td>
</tr>
<tr>
<td>Round Corners</td>
<td>Toggles a Rectangle element to rounded or squared corners.</td>
</tr>
<tr>
<td>Thickness</td>
<td>Thickness of the lines of the element in pixels.</td>
</tr>
</tbody>
</table>
### Property Description

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Include in Printout</td>
<td>Determines whether the element is displayed when the form is printed. If this property is not selected, the element appears in the patient chart, but not in any printouts.</td>
</tr>
<tr>
<td>Draw Box Border</td>
<td>Draws a border around the element. If you are designing the form from an image or PDF, turn this off; if designing from scratch, turn it on.</td>
</tr>
<tr>
<td>Event Triggered</td>
<td>Specifies a name for the action that this element will trigger. For information, see &quot;Defining events&quot; on page 65.</td>
</tr>
</tbody>
</table>

### Resizing individual elements

You can resize elements several ways. You can drag the element’s boundaries by using the mouse or set width and height properties (if available) in the **Properties** pane.

You may also want to use keyboard shortcuts to resize elements.

**Step**

- In the edit area, select the element, hold down the Shift key, and press the appropriate arrow key:
  - Right to increase width
  - Left to decrease width
  - Up to decrease height (brings the bottom edge up)
  - Down to increase height (brings the bottom edge down)

### Resizing all elements and locations

You can resize all elements and their locations on the custom form at the same time. For example, if you increase the height of the form page, you may want to increase the size of its elements as well.

You specify a scale factor, relative to "1". For example, to reduce the size of all elements by half, use a scale factor of “0.5”. To increase the size of all elements by half, use a scale factor of “1.5”.

**Steps**

1. From the forms editor toolbar, choose **File > Utilities > Scale Locations and Sizes**.
2. Type the scale factor and click **OK**.
Aligning elements

You can line elements up horizontally or vertically.

Steps
1. In the edit area, select the elements that you want to line up.
2. Do one of the following:
   - To align elements evenly by their left sides, choose Edit > Align Selected Horizontally. Alternatively, select the fields that you want to align, click in the Y property, then press Enter (Return).
   - To align elements evenly by their tops, choose Edit > Align Selected Vertically. Alternatively, select the fields that you want to align, click in the X property, then press Enter (Return).

Reordering elements

You can change the order of elements, which is useful for organizing elements that overlap.

Steps
1. In the edit area, select the element that you want to reorder.
2. From the forms editor toolbar, choose Edit > Send to Back or Bring to Front.

Defining user interface options as mutually exclusive

For elements that the user can select, you can make two or more mutually exclusive. For example, the custom form may provide three checkboxes for choosing how the patient found out about your clinic. If you want to allow users to select only one of the three checkboxes, make them mutually exclusive. The user will be able to select only one of the checkboxes at a time.

Steps
1. In the edit area, select two or more elements that you want to make mutually exclusive.
2. From the forms editor toolbar, choose Edit > Group Items as Mutually Exclusive.
Applying tab order to multiple elements

Users can navigate the custom form by tabbing from one field to the next. You can precisely define the order of fields by using the Tabbed Order property for each element. You may find it more convenient to specify the tab order for multiple selected objects at the same time.

When specifying the tab order for multiple selected elements, you provide the initial order value. The system automatically applies order values for each selected element, in left-to-right order, per line. A line is considered at least 5 pixels below a previous “line”. System order values are applied in increments of 10, starting from the initial value you provided.

The system notifies you of the tab order value for the last element on the custom form. If you add elements to the custom form and you want to specify a tab order value, you would typically start with this value.

Steps

1. In the edit area, select the elements.
2. From the forms editor toolbar, choose Edit > Apply Left-To-Right Tab Ordering to Selection.
3. Type the value for the first element’s tab order and click OK.
4. Click OK to confirm the message, indicating the tab order value of the last element on the custom form.

Defining events

You can link elements so that, when one is selected, it affects the visibility or value of another. Here are some examples:

- When a Check Box element is selected, a related one is automatically selected as well.
- When an item is selected from a Combo Box element, another element is hidden (or shown).
- When a Radio Button element is selected, the value in a text field is set to 25.

Defining events involves the following tasks:

- First, set the event trigger (the checkbox, radio button, or button that initiates the event when a user clicks it).
- Then, set the event handler (the result of the event trigger).

Be sure to fully test any events you define in a custom form before allowing it to be used in patient charts.
If you use more than one trigger, you must set up handlers to clear what the other triggers and handlers may have done previously.

**Setting the event trigger**

To define events, you need to assign an event name to the element that is going to trigger the action. Elements that can trigger events include **Check Box**, **Radio Button**, **Combo Box**, or **Button**.

**Steps**

1. In the edit area, select the element that is going to trigger the action when it is selected.
2. In the **Properties** pane, in the **Event Triggered** property, type a name for the event.

**Setting the event handlers**

After assigning an event name to the element that is going to trigger the action, you define how the event will be handled, which includes identifying the following things:

- Element whose value or visibility is going to be changed when the trigger happens
- Action to be taken

An element can have multiple event handlers defined, which can be very helpful in forms such as a lab requisition.

It's a good idea to include a button on the form that resets all fields back to their default, so that the user doesn’t need to delete the form and re-insert it if they make a mistake (see "Examples of events in custom forms" on the next page).

**Steps**

1. In the edit area, select the element that you want the action to be performed on.
2. In the **Properties** pane, in the **Event Handlers** property, click **Add**.
3. Type the name of the event that will trigger this action.

You defined the event name, using the **Event Triggered** property for the element that will initiate the action when selected.

4. Select the condition for the trigger by using the list box following **If the event value is**:

   - **anything** usually applies to Button elements.
   - **equal to** or **not equal to** usually applies to list items in a Combo Box element. See "Examples of events in custom forms" below.
   - **selected** or **unselected** usually applies to Check Box or Radio Button elements.

5. Using the list box following **then change the**, specify whether to change the visibility or value of the target element when the trigger condition is met:

   - To change the visibility, select **visibility**, and select **true** or **false**.
   - To change the value, select **value**, and then select the value to be used. If you are defining the action for an element that does not display a value (for example, a Check Box), select **true** or **selected** (see "Examples of events in custom forms" below).

6. Using the list box following **of this item**, specify the action related to the visibility or value:

   - For **visibility**, select **true** or **false**.
   - For **value**, type the value to be used or leave the field blank to clear the value of a text field. If the element does not display a value (for example, a Check Box), type **true** or **selected** (see "Examples of events in custom forms" below).

   **To test your entries, choose Custom Form > Test Event Triggered by Selected Item.**

**Using custom scripts**

Events can be defined by using custom JavaScript functions (such as do a medical calculation such as an anion gap or submit data to a web page). Custom scripts require contractual development work. For more information, contact the PS Suite EMR support team.

Once the scripts have been developed, put the function name in the **Event Triggered** property and leave the **Event Handlers** property blank.

**Examples of events in custom forms**

The following examples show how you can use events in custom forms.
Example 1: Checkbox

When checkbox #1 is selected, a related one is automatically selected as well:

- Check Box #1 = Event Triggered = event1
- Check Box (related) = Event Handlers = “When the event named [event1] fires, if the event value is [selected], then change the [value] of this item to [true].”

Example 2: Combo box

When the user selects an item from a combo box list, other elements are hidden (or shown). In this example, if item 1 is chosen, element “(a)” is hidden. If item 2 is chosen, element “(b)” is hidden. Element “(c)” is hidden by default, but becomes visible if item 3 is chosen.

- Combo Box list items 1,2,3,4
- Combo Box Event Triggered = event2
- Element (a) Event Handlers = “When the event named [event2] fires, if the event value is [equal to] [1], then change the [visibility] of this item to [false].”
- Element (b) Event Handlers = “When the event named [event2] fires, if the event value is [equal to] [2], then change the [visibility] of this item to [false].”
- Element (c) Visible = unselected
- Element (c) Event Handlers = “When the event named [event2] fires, if the event value is [equal to] [3], set the [visibility] of this item to [true].”
Example 3: Button

When the user selects a specific button, all fields reset to their defaults.

1. Create a Button element with the Event Triggered property set to ResetDefaults.

2. For each element on the form that has Event Handlers defined (regardless of the event fired), add another Event Handler that initiates the ResetDefaults event and resets the element’s value or visibility to its default value. In effect, you will be entering the reverse of any other Event Handler defined for that element.

Making fields mandatory

You can make certain fields in your custom form mandatory so that users must fill them in when they complete your form. You use the Required property to mark an element as mandatory.

A red asterisk appears to the left of the text item to indicate that this field is required. Pair this property with a validation button that uses the Id “validateForm”, so that when users click the button, a message pops up if they failed to fill in a required field. Missing fields are also highlighted in red.

The pop-up message also warns users if they entered text in the wrong format (as defined by the Format As property). For more information, see “Text element properties” on page 41.
Steps

1. Click the element that you want to make mandatory.

2. In the properties pane, select the Required checkbox.

3. Add a validation button.
   - In the drawing toolbar, click the Button tool and insert the button in your form.
   - In the Properties pane, in the Id field, type validateForm.
   - Type a Name and the Text that you want to appear on your button (such as Validate).

Making sections collapsible

You can define collapsible sections within your form so that content can be hidden and then shown. This is useful to claim space within the form or to add conditions within your form so that you can show different follow-up fields depending on the answer provided. For example, if you have Yes and No radio buttons, you can show one set of additional items if the user selects Yes and a different set of items if the user selects No. This makes your forms interactive and easier for users to fill in by reducing the number of fields in the form for the user and by only showing the user relevant fields.
Collapsible sections always span the entire width of the form. Ensure that you arrange the items that you want collapsed so that they appear on the same Y (horizontal) axis. When collapsed, items below the section shift up to reclaim the space. When the section is expanded again, the items below shift back down.

When designing custom forms with collapsible sections, you must always use event triggers and event handlers to control showing or hiding the sections. For example, if you want to hide an entire section, add hide and show buttons or text in a header above your section. Or, if you want to add conditions, such as the Yes and No buttons described above,

**Steps**

1. **In the drawing toolbar, click the Collapsible section tool**.

2. **In your custom form, click the top area of the section that you want to make collapsible and drag your mouse to the bottom of the section.**

3. **The section is bordered by red dashed lines and by a red rectangle in the left margin. If needed, adjust the position using the Y and Height properties.**

   All of the items that appear between the dashed lines are part of the collapsible section.

4. **If you have multiple collapsible sections, change the Colour property to easily tell them apart.**

5. **In the Event Handlers property, add event triggers to control the visibility of the section. There should be one handler to control showing the section and one to control hiding the section.**
To collapse and expand an entire section, add hide and show buttons or links in a header above your section (as shown above, in the first example).

To collapse or expand a section based on the answer to a previous field (for example, making answers conditional), add two Event Handlers for each section; one to show the section and one to hide the section. Then, in your element that controls the section, in the Event Triggered property, specify the name of your Event Handler.

For more information, see “Defining events” on page 65.

6. If you do not want the section to be visible when first inserting the form in a patient record, clear the Visible checkbox. This is useful when adding sections that are conditional.

7. If you want to clear the data entered when a section is collapsed, select the Clear collapsed values checkbox.

Adding instructions for using a custom form

You can define instructions for using the form. These instructions are displayed to the user when choosing a form. The instructions are displayed above the preview of the form.

Steps

1. From the forms editor toolbar, choose Custom Form > Edit Instructions.

2. Type the instructions and click OK.
Setting defaults for a custom form

You can define defaults that determine how custom forms are displayed in patient charts. These defaults include:

- "Using values from a previous custom form" below
- "Collapsing the custom form by default in patient charts" below
- "Showing the custom form in patient reminders" on the next page (including a global reminder in the custom form)
- "Locking the EMR when viewing a custom form" on the next page
- "Setting a default fax recipient for a custom form" on the next page

Using values from a previous custom form

You can specify that when a custom form is inserted in a patient chart, user-entered values from a previous instance of the form in that patient’s chart are displayed by default. This feature is useful for quickly completing forms that you use repeatedly for the same patient.

**Step**

- From the forms editor toolbar, choose **Edit > Use Previous Form’s Values**.

Collapsing the custom form by default in patient charts

When a custom form is inserted in a patient chart, the form is open to enable users to complete it. You can set the custom form to collapse in the patient’s chart by default when accessed in the future. Collapsing the form saves space in the patient chart, which minimizes the amount of scrolling required when working with the patient chart. Users can expand the custom form at any time to view it.

When collapsed, the form’s title appears in the patient’s chart, along with a link that opens the form for viewing.

| May 8, 2012 | New Patient Interview (Click to expand) | JMK |

**Steps**

1. From the forms editor toolbar, choose **Custom Form > Collapse in Notes View by Default** and verify that a check mark appears beside this option.
2. If you want users to choose whether a custom form remains expanded, choose **Custom Form > Remember Custom Form Collapsed State** and verify that a check mark appears beside this option. When a user expands the custom form in the patient chart and then saves the file, the form will remain expanded the next time that the user opens this patient chart.

Showing the custom form in patient reminders

Reminders are a proactive, rules-based, live screening function that can be customized to your practice. Users can define global reminders to add intervention notes for all patients that match search criteria. You can make custom forms available to users when defining global reminders. When the reminder applies to a specific patient, the custom form is inserted in the REM section of the patient profile.

**Step**

- From the forms editor toolbar, choose **Custom Form > Allow this Form to Show in Profile with Reminders**.

Locking the EMR when viewing a custom form

You can set up a custom form such that users can view and complete it prior to inserting it into a patient’s chart. The form opens in a separate window, populated with patient data.

When accessing custom forms using this method, you may want to lock PS Suite EMR. This security feature is useful if you want to enable patients to complete the form, ensuring that they don’t have access to the print, email, and fax options for this form, or the system itself. Once the form has been completed, an authorized user can review the information, log back into the system, and insert the form in the patient chart.

**Step**

- From the forms editor toolbar, choose **Custom Form > Lock the Screen When Viewing the Form**.

Setting a default fax recipient for a custom form

Many custom forms are always faxed to the same location and fax number. Instead of choosing the recipient from your Address Book each time you fax the form, you can set a default fax recipient for that form. When you fax the custom form from a patient’s chart, this recipient is auto-populated for you (but can be changed).
Steps

1. From the forms editor toolbar, choose **Custom Form > Default Fax Recipient...**

2. In the **Address Search** window, search for an addressee. You can select an addressee from your local Address Book, or from the Provider Registry if MedDialog or Prescribel™ are enabled on your system.

3. After selecting an addressee, a checkmark displays beside the **Default Fax Recipient...** menu option to indicate the form has a default fax recipient set. To remove the default fax recipient, click **Default Fax Recipient...** to clear the checkmark.

Testing a custom form

Be sure to frequently and fully test your form before allowing it to be used in patient charts. While creating your form, save often.

Steps

1. From the forms editor toolbar, choose **File > Test Print** to see how the form would print from the patient’s chart.

2. Insert the form into a dummy patient chart to test usage and to test the behaviour of any triggered events.

3. Print the form from the patient chart.

Editing an existing custom form

As a best practice, when editing forms on a live system, create a copy of the form, include “DO NOT USE” in the name and make your changes in the copy. Once the form is tested and is ready for use, rename the form and remove “DO NOT USE”.

Editing an existing custom form will not affect previous versions of the form that were inserted and filled in within patient charts. The progress notes will retain the original version of the form that was inserted. Any new progress notes created with the form will use the most recent version.

Steps

1. From the forms editor toolbar, click **Settings > Edit Custom Forms**.

2. In the list of existing custom forms, select the one that you want to edit.
3. Click **Duplicate Form**.

4. Type a name for the copy of the custom form and click **OK**.

**Viewing the revision history of a custom form**

You can track the history of changes that are made to a custom form or encounter assistant (EA). Each form includes version IDs and each saved change generates a new version of the form. You can view each version and revert to a past version, if needed.

Reverting to a past version is useful when you have customized a standard form but kept the original form’s name. When you receive an updated version of the standard form from TELUS Health, you can then view your previous customized version and give it a different name. As a best practice, always create a duplicate of the standard form that you want to customize so that your changes are not overwritten when TELUS Health publishes a new version.

If a form or EA that was inserted into a patient chart is modified at a later date, the version that is in the patient chart will be unaffected. The progress note will retain the original version of the form that was inserted. Any new progress notes created with the form will use the most recent version of the form.

**Steps**

1. From the **Records** window, choose **Settings > Edit Custom Forms**.

2. From the list, select a form.

3. From the **File** menu, choose **Show Revision History**.

4. Click a version to view the form.
5. If you want to make a previous version of the form the active version, select the version and click **Choose This Form**. When users add this form in a patient record, this version will be inserted.

### Attaching a custom form to letters

You can attach custom forms as a separate page to letters. You can choose to use the system’s current default salutation, closing, or both the salutation and closing.

**Steps**

1. If you want to use the system’s current default salutation, choose **Custom Form > Use Default Salutation in Attaching Letter**.

2. If you want to use the system’s current default salutation, choose **Custom Form > Use Default Closing in Attaching Letter**.

### Removing a custom form

If a custom form or an Encounter Assistant is no longer needed, you can deactivate it so that no one uses it. Before deactivating, ensure that no one in the clinic still needs to use the old form or Encounter Assistant. For example, when you update a lab requisition or [WorkersComp] form, you will want to remove the old form.
Deactivating a form or Encounter Assistant does not affect or delete any forms that were previously added in patient charts. Those remain a permanent part of the patients’ records.

Deactivating also does not permanently delete the form or Encounter Assistant from the system. It can always be reactivated at a later time.

**Steps**

1. To deactivate a form or Encounter Assistant:
   - From the Records window, choose Settings > Edit Custom Forms.
   - From the list, select the form or Encounter Assistant to deactivate.
   - From the File menu, choose Deactivate Custom Form and confirm the deactivation.

2. To reactivate a form or Encounter Assistant:
   - From the Records window, choose Settings > Edit Custom Forms.
   - From the File menu, choose Restore Deactivated Forms.
   - Select the form to reactivate and click Choose This Form.

**Consultation request custom forms**

If a custom form is saved with the type Consultation Request Template, it can be used as a new consultation template in the Managing Received Documents window.

TELUS Health provides the following custom form, which you can modify, if needed.

**Consultation Request - V2**

This custom form collects basic information required for a new consultation request.
Customizing Consultation Request Template custom forms

If you have purchased the separate custom forms licence and training, you can modify the Consultation Request - V2 custom form that TELUS Health provides or edit your existing consultation request custom forms to make them work with the consultation request workflow.

You will be prompted for the licence key the first time that you create a custom form. If you do not have this licence key, contact the PS Suite EMR Technical Assistance Centre.

You can change the urgency levels and referral statuses to better suit the needs of your practice. You can also create multiple consultation request custom forms to track different workflows. For example, an endocrinologist may have a different workflow for a diabetic patient versus a thyroid patient.

If you have more than one consultation request custom forms, you can choose which one to use in the Managing Received Documents workflow.

As a best practice, when editing forms on a live system, create a copy of the form, include “DO NOT USE” in the name and make your changes in the copy. Once the form is tested and is ready for use, rename the form and remove “DO NOT USE”. Editing an existing custom form will not affect previous versions of the form that were inserted and filled in within patient charts. The progress notes will retain the original version of the form that was inserted. Any new progress notes created with the form will use the most recent version.

To properly work in the Managing Received Documents workflow, your custom forms must be saved as a Consultation Request Template type and must contain the following named fields.
Creating and designing custom forms

Name of field in custom form (case sensitive) | Type of field
--- | ---
(selectable from the Custom Form > Custom Form Type menu of the full custom forms editor) | Consultation Request Template type
Referral Doctor | Text Field
Referral Reason | Text Area
<table>
<thead>
<tr>
<th>Name of field in custom form (case sensitive)</th>
<th>Type of field</th>
</tr>
</thead>
<tbody>
<tr>
<td>Referral Date</td>
<td>Text Field</td>
</tr>
<tr>
<td>Referral Urgency</td>
<td>Dropdown menu</td>
</tr>
<tr>
<td>Referral Details</td>
<td>Text Area</td>
</tr>
<tr>
<td>Referral Status</td>
<td>Dropdown menu</td>
</tr>
<tr>
<td>Referral Comments</td>
<td>Text Area</td>
</tr>
</tbody>
</table>

**Steps**

1. From the forms editor toolbar, click **Settings > Edit Custom Forms**.
2. In the list of your existing custom forms, select the one that you want to edit.
3. Click **Duplicate Form**.
4. Type a name for the copy of the custom form and click OK.
5. From the **Custom Form** menu, choose **Custom Form type** and then choose **Consultation Request Template**. This saves the custom form as a consultation request so that it will become available from the **Manage Received Documents** workflow in the **Records** file.
6. Ensure that the form includes all of the fields listed above and that each field uses the required **Name**.

7. To modify the choices for the **Urgency** or **Status**, click the drop-down object and then click the **Items** field in the properties pane. Choose whether to **Add** or **Remove** items from the list.

Do not edit other properties for the **Urgency** and **Status** items.
8. Save your changes.

Demographics custom forms

You can save a custom form with the type **Extended Demographics** to allow a user to view and add only a specific type of custom form in a patient’s chart without providing access to the rest of the data in the chart. For example, in offices where staff fill out a custom form to gather detailed demographic data about a patient beyond what is recorded in the **Patients** file. You can set this as the type for any custom form that you want users to insert and view in the chart without seeing or entering any other medical data; it does not necessarily need to relate to demographics.

**Steps**

1. In the custom forms editor, choose **Custom Form > Custom Form Type...** and select **Extended Demographics**.
2. From the main toolbar choose **Settings > Edit Users**. Ensure the appropriate users have **View Privileges of Only Own Notes, Shared Notes, Messages, and Demographics Custom Forms** and **Action Privileges of Demographics Custom Forms**.
Designing toolbar custom forms

Toolbars use customized JavaScript code to make the functionality work as described, but you do not need to know JavaScript coding. Therefore, to create a new toolbar, you must always use a copy of the template provided by TELUS Health. Before you create or edit a toolbar, an existing toolbar custom form must already be imported in your PS Suite EMR. You can download the toolbar template and view training videos in the online help (see "Custom forms library" and "Training videos").

Design tips

- As a best practice, when editing forms on a live system, create a copy of the form, include “DO NOT USE” in the name and make your changes in the copy. Once the form is tested and is ready for use, rename the form and remove “DO NOT USE”.

- Make your toolbar as narrow as practical to fit across the Records file. You should determine what screen resolution is typically used in your office and how big the Records window is on the screen. Toolbars do not wrap when the Records window is resized, so links may be cut off from the edge on smaller windows.

- You can edit the font and placement of the items (for example, place all items on a single row or on two rows).

- Label your actions with short names (using the Text property) that describe what they do and use a tooltip to explain the action in more detail to the user. For example, if you use the Insert Form link to create a lab requisition, name the link “Lab Req” and use the Tooltip Text property to provide a longer and more detailed explanation of what the item does.

- By default, in the template, the items are not visible. You can therefore keep all items in the template while you are designing and configuring your own toolbar and only make visible the ones that you want in your toolbar.

- Duplicate items in the template before making them visible, to allow easy re-use of an item.

Single click vs drop-down lists vs picker list

The toolbar template includes the ability to add items via a single click, through a drop-down list, or through a "picker" list.
Single-click items insert a single item in the patient’s chart (such as one stamp, one custom form, one diagram, and so on).

The drop-down list enables you to provide a choice of items to insert in the patient’s chart. Copy the list and use it to insert your favourite actions (such as stamps, letters, forms, flowsheets) or to access some of your more common actions (prescriptions, searches, or supercode bills). The list enables you to group similar items within a list instead of having to create several single-click items.

The use as picker item enables you to create a list of items to choose from, but instead of a drop-down list you can have a button that displays the list in a separate window. The list of items is the “picker” form, and the Add to Notes option is not available. Using a picker instead of a drop-down list allows more room for displaying the name of the items in the list, and you can format the list in any way you’d like.

**Steps**

1. From the Records window, choose Settings > Edit Custom Forms.
2. Select the toolbar template (or another existing toolbar custom form that you want to edit) and click Duplicate Form.
3. If you are prompted to enter a licence key, type it in the box provided and click OK.
4. Type a name for the new form and click OK.
5. Select the desired action item in the toolbar, duplicate it, and configure its properties:
   - Select the Visible checkbox.
   - Type the Text that will appear on the toolbar.
   - Optionally, type Tooltip Text to describe what the action does.
6. Define the Resource Name or any other properties needed by the specific item. See "Toolbar Template form" on the next page for a summary of each item and the properties to be defined.
7. Save the toolbar.
8. Create a reminder to activate the toolbar within patients’ records.

**Toolbar Template form**

A toolbar is a custom form associated to a reminder and contains all of the necessary code to perform a number of actions quickly within a patient’s chart. The **Toolbar Template form** serves as a base to create your own toolbar. The template itself does not “do” anything; you must duplicate and then customize it to meet your needs and workflow.
You can download the toolbar template from the Canada-wide custom forms library in the PS Suite online help.

To configure toolbars, you must have a custom forms licence.

In the template, you should duplicate the items you want to use, then make those items Visible and replace the appropriate properties with content so that they appear in your toolbar.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bill Subcode</td>
<td>Creates a bill using a supercode</td>
</tr>
<tr>
<td>Insert Diagram</td>
<td>Inserts a diagram defined by the Resource Name</td>
</tr>
<tr>
<td>Insert Form</td>
<td>Inserts a custom form defined by the Resource Name</td>
</tr>
<tr>
<td>Insert Letter</td>
<td>Creates a letter from a stamp</td>
</tr>
<tr>
<td>Insert Note</td>
<td>Creates a progress note from the text in the Resource Name</td>
</tr>
<tr>
<td>Insert Stamp</td>
<td>Creates a progress note from a stamp</td>
</tr>
<tr>
<td>Intake Form</td>
<td>Looks for a custom form (as defined by Resource Name) in the chart and scrolls to it</td>
</tr>
<tr>
<td>Letter to Patient</td>
<td>Creates a letter addressed to the patient using a stamp as the letter body</td>
</tr>
<tr>
<td>Open URL</td>
<td>Opens a URL in the browser</td>
</tr>
<tr>
<td>Perform Treatment</td>
<td>Performs a treatment (Ctrl+J)</td>
</tr>
<tr>
<td>Prescription</td>
<td>Create a prescription (Ctrl+B) from a Rx Favourite (use + or , or ; to add multiple values)</td>
</tr>
<tr>
<td>Search</td>
<td>Run a predefined search</td>
</tr>
<tr>
<td>Send Email</td>
<td>Sends an email to the patient using a stamp as the message body</td>
</tr>
<tr>
<td>Send Message</td>
<td>Sends a message to another PSS user</td>
</tr>
<tr>
<td>Show Flowsheet</td>
<td>Opens a flowsheet as defined by the Resource Name</td>
</tr>
<tr>
<td>Show Graph</td>
<td>Graphs one or more values (use + or , or ; to separate them)</td>
</tr>
<tr>
<td>Track Form</td>
<td>Display the data that a form was last created and scroll to it when clicked</td>
</tr>
<tr>
<td>View Handout</td>
<td>Opens a handout for printing</td>
</tr>
<tr>
<td>View Filter</td>
<td>Define a one-click filter on the chart</td>
</tr>
<tr>
<td>View Form</td>
<td>Opens a custom form in a floating window (&quot;F2&quot; mode)</td>
</tr>
</tbody>
</table>

Create a drop down list of "favourite" actions.

1. Define the Resource name of the dropdown with a label.
2. Create one or more actions using the links above (make them invisible)
3. Assign the Section ID of each action link to the label used in Step 1.
4. Items will be sorted by Tab Order and then alphabetically

Show overdue items

<table>
<thead>
<tr>
<th>Date</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jan 1, 2022</td>
<td>1. Create a text field and use the Patient Property... Inspector to pick some date of latest</td>
</tr>
<tr>
<td></td>
<td>Name the date field &quot;&lt;something&gt; Last Done&quot; and make sure it is visible</td>
</tr>
<tr>
<td></td>
<td>3. Use a shape, caption or picture and name it &quot;&lt;something&gt; Due&quot; and assign its Section ID to &quot;Overdue&quot;</td>
</tr>
<tr>
<td></td>
<td>Use the resource property of the date item to indicate the interval (use y, m or d)</td>
</tr>
</tbody>
</table>

Show abnormal values

<table>
<thead>
<tr>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>S</td>
<td>1. Create a text field and use the Patient Property... Inspector to pick some numeric value</td>
</tr>
<tr>
<td></td>
<td>Name the date field &quot;&lt;something&gt;&quot; and make sure it is visible</td>
</tr>
<tr>
<td></td>
<td>3. Use a shape, caption or picture and name it &quot;&lt;something&gt; Abn&quot;</td>
</tr>
<tr>
<td></td>
<td>Use another text item and define the target. Name it &quot;&lt;something&gt; Target&quot; and make sure its Section ID is &quot;Targets&quot;. You can define the target as the text field and you can use another name item by enclosing its name in square brackets (eg. [Another Item]).</td>
</tr>
</tbody>
</table>

Most recent date

<table>
<thead>
<tr>
<th>Date</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jan 1, 2022</td>
<td>1. Create a text field and use the Patient Property... Inspector to pick a date value</td>
</tr>
<tr>
<td></td>
<td>2. Create additional text fields for all the possible dates.</td>
</tr>
<tr>
<td>Jan 1, 2018</td>
<td>3. Create an empty text field and make the Section ID &quot;Most recent date&quot; and make sure the Resource Name is &quot;Something&quot;</td>
</tr>
<tr>
<td>Jan 1, 2016</td>
<td>4. Go back to the possible text dates, and make sure the Section ID is &quot;Something&quot;</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Intake</th>
<th>Visit</th>
<th>Immunization</th>
<th>Growth</th>
<th>Due ndds,</th>
<th>Due</th>
<th>Requisitions</th>
</tr>
</thead>
</table>

This is a quick reference to outline the items, or actions, that are available in the template. For full details on configuring and using your toolbar template, see the PS Suite Custom Forms Guide in the online help.
<table>
<thead>
<tr>
<th>Item in toolbar</th>
<th>Description</th>
<th>Resource Name</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bill Supercode *</td>
<td>Creates a new bill using a supercode.</td>
<td>Name of supercode</td>
<td>■ Must use supercode, cannot specify a single billing code.</td>
</tr>
<tr>
<td>Insert Diagram *</td>
<td>Inserts a diagram into the chart.</td>
<td>Name of diagram</td>
<td></td>
</tr>
<tr>
<td>Insert Form *</td>
<td>Inserts a custom form into the chart.</td>
<td>Name of custom form</td>
<td>■ Insert multiple custom forms by separating them with a comma, semi-colon, or + sign.</td>
</tr>
<tr>
<td>Insert Letter *</td>
<td>Creates a new letter using a stamp.</td>
<td>Name of letter stamp</td>
<td>■ Letter is addressed to Referring MD/NP from demographics, otherwise &quot;To Whom It May Concern&quot;.</td>
</tr>
<tr>
<td>Insert Note *</td>
<td>Creates a new progress note.</td>
<td>Text of note</td>
<td>■ Can use keywords, such as patName.</td>
</tr>
<tr>
<td>Insert Stamp *</td>
<td>Creates a new progress note using a stamp.</td>
<td>Name of stamp</td>
<td></td>
</tr>
<tr>
<td>Intake Form</td>
<td>Scrolls to that custom form in the chart.</td>
<td>Name of form</td>
<td></td>
</tr>
<tr>
<td>Open URL *</td>
<td>Opens your default web browser to a specific URL.</td>
<td>n/a</td>
<td>■ Type the URL in the Associated URL property.</td>
</tr>
<tr>
<td>Perform Treatment *</td>
<td>Opens the New treatment window with the Name field(s) populated.</td>
<td>Partial name of treatment of immunization, or prescription favourite name(s)</td>
<td>■ Prescribe multiple treatments by separating them with a comma, semi-colon, or + sign.</td>
</tr>
<tr>
<td>Prescription *</td>
<td>Opens the Prescription window with the Name field(s) populated.</td>
<td>Partial medication name (s), or prescription favourite name(s)</td>
<td>■ Prescribe multiple treatments by separating them with a comma, semi-colon, or + sign.</td>
</tr>
<tr>
<td>Item in toolbar</td>
<td>Description</td>
<td>Resource Name</td>
<td>Notes</td>
</tr>
<tr>
<td>-----------------</td>
<td>-------------</td>
<td>---------------</td>
<td>-------</td>
</tr>
</tbody>
</table>
| Search*         | Runs a predefined search. | Name of search | - Not limited to a specific provider’s patients (unless specified as criteria in the search itself).  
- To modify the report template, run the search manually first and save the template. |
| Send Email      | Sends an email to the current patient. | Body of the email. You can insert a stamp. | - Type the message subject in the **Tooltip Text** property. The default subject of the email is "A message from your doctor". |
| Send Message    | Sends a new message to the recipient. | Body of the message. You can insert a stamp. | - Type the message subject in the **Tooltip Text** property. Leave blank to be prompted.  
- Type the initials of the recipient (individual user or a messaging group) in the **Section ID** property. Type MD to send a message to the patient’s doctor. Leave blank to be prompted.  
- Type the # of days until the message is due in the **Tab Order** property. Type 0 for ASAP. Type -1 to be prompted. |
| Show Flowsheet* | Displays a flowsheet for that patient. | Name of flowsheet | |
| Show Graph*     | Displays a graph of the specified value(s). | Value(s) you want to graph, such as wt: | - Graph multiple items on the same graph by separating them with a comma, semi-colon, or + sign. |
| Track Form      | Displays the date of the most recent instance of the custom form in the chart. | Name of custom form | - Click the date to go to that form in the chart.  
- Click **never done** to add that form to the chart. |
<table>
<thead>
<tr>
<th>Item in toolbar</th>
<th>Description</th>
<th>Resource Name</th>
<th>Notes</th>
</tr>
</thead>
</table>
| View Filter    | Filters the chart to show only notes that you specify. | Keyword to identify the filter | - Precede by **My** to filter notes with your initials.  
- Precede by **Dr** to filter notes created by doctors.  
- Equivalent to the filter options in the **View** menu.  
- Type **Contains=?** to be prompted for text and to show only notes that contain that text (same functionality as **View > Only Notes Containing**). |
| View Form      | Displays a custom form in a separate window. | Name of custom form | |
| View Handout   | Opens a handout in a PDF viewer. | Name of handout | - Only PDF handouts. Use “printHandout” as the Click Event for text handouts. |
| Drop-down list | Creates a drop-down list of items to insert in the patient chart. | Unique name for the list | - Give the same name in the Section ID property to items that you want to appear in the list. |
| Use as picker  | Creates a list of items to insert in the patient chart | n/a | - If checked, the picker window closes after you select a resource. If unchecked, the picker window stays open after you select a resource.  
- Use instead of a drop-down list to allow for formatting the list  
- Cannot insert a "picker" form into the notes |
| Show overdue items | Displays **Due** and/or outlines a field in red | The overdue interval in years, months, or days | - Name the date field being tracked as "name Last Done" and set an overdue interval  
- Name the overdue alert item "name Due" and set the Section ID to "Overdue" |
### Items within toolbar custom forms

You can insert the following items within a toolbar custom form. The toolbar template form includes all of these items. Click an item’s link to see detailed steps and information.

- "Bill Supercode toolbar item" on the next page
- "Insert Diagram toolbar item" on page 93
- "Insert Custom Form toolbar item" on page 94
- "Insert Letter toolbar item" on page 95
- "Insert Note toolbar item" on page 96
- "Insert Stamp toolbar item" on page 97
- "Letter to Patient toolbar item" on page 97
- "Open URL toolbar item" on page 98
- "Perform Treatment toolbar item" on page 99
- "Prescription toolbar item" on page 99
- "Search toolbar item" on page 101
- "Send Email toolbar item" on page 101
- "Send Message toolbar item" on page 102
- "Show Flowsheet toolbar item" on page 103
- "Show Graph toolbar item" on page 104
- "Track Form toolbar item" on page 104
- "View Filter toolbar item" on page 105
- "View Form toolbar item" on page 107
- "View Handout toolbar item" on page 108
- "List toolbar item" on page 109
- "Use as picker toolbar item" on page 111
- "Show overdue items toolbar item" on page 112
- "Show abnormal values toolbar item" on page 113
- "Most recent date toolbar item" on page 114

**Bill Supercode toolbar item**

Use the Bill Supercode toolbar item in a toolbar custom form to open the Bill Book of the current billing doctor and bill a pre-defined supercode (bill template). You must specify the following properties for this item.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource Name</td>
<td>Choose the blank area and type the name of the supercode to bill.</td>
</tr>
<tr>
<td>Text</td>
<td>Type the label text to appear in the toolbar.</td>
</tr>
<tr>
<td>Click Event</td>
<td>Leave as billSupercode (do not edit).</td>
</tr>
</tbody>
</table>

**Example**

![Designing toolbar custom forms](image)
If you are editing an older toolbar custom form, you can also use the following property: 

**Click Event** = `createBill("SupercodeName")`, where you replace “SupercodeName” with the exact name of an existing supercode within quotation marks. Example: `createBill("WellBaby")`

---

**Insert Diagram toolbar item**

Use the **Insert Diagram** item in the toolbar template to insert a diagram in the chart. You must specify the following properties for this item.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource Name</td>
<td>Choose <strong>Select Diagram</strong> and choose your diagram. To insert multiple diagrams, separate them by a comma, semi-colon, or + sign.</td>
</tr>
<tr>
<td>Text</td>
<td>Type the label text to appear in the toolbar.</td>
</tr>
<tr>
<td>Click Event</td>
<td>Leave as <strong>insertDiagram</strong> (do not edit).</td>
</tr>
</tbody>
</table>

---

**Example**

![Insert Diagram Example](image_url)

---

**Table showing the properties and settings for the insertDiagram item**

<table>
<thead>
<tr>
<th>Resource Name</th>
<th>Faces</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tab Order</td>
<td>0</td>
</tr>
<tr>
<td>Editable</td>
<td></td>
</tr>
<tr>
<td>Justification</td>
<td>left</td>
</tr>
<tr>
<td>Associated URL</td>
<td></td>
</tr>
<tr>
<td>Max Length</td>
<td>0</td>
</tr>
<tr>
<td>Link Click To</td>
<td></td>
</tr>
<tr>
<td>Click Event</td>
<td><strong>insertDiagram</strong></td>
</tr>
</tbody>
</table>

---

Designing toolbar custom forms
Insert Custom Form toolbar item

Use the Insert Custom Form item in the toolbar template to insert a single custom form or encounter assistant in the chart. You must specify the following properties for this item.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource Name</td>
<td>Choose Select Custom Form and choose a custom form or encounter assistant. To insert multiple forms at once, after you choose the first form, click the form name, and, in the Input window, type the exact name of additional forms, separated by a comma, semi-colon, or + sign (such as 2013 Lab Requisition, CDM Diabetes).</td>
</tr>
<tr>
<td>Text</td>
<td>Type the label text to appear in the toolbar.</td>
</tr>
<tr>
<td>Click Event</td>
<td>Leave as insertCustomForm (do not edit).</td>
</tr>
</tbody>
</table>

Example

<table>
<thead>
<tr>
<th>Resource Name</th>
<th>2013 Lab Requisition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tab Order</td>
<td>0</td>
</tr>
<tr>
<td>Editable</td>
<td></td>
</tr>
<tr>
<td>Justification</td>
<td>left</td>
</tr>
<tr>
<td>Associated URL</td>
<td></td>
</tr>
<tr>
<td>Max Length</td>
<td>0</td>
</tr>
<tr>
<td>Link: Click To</td>
<td></td>
</tr>
<tr>
<td>Click Event</td>
<td>insertCustomForm</td>
</tr>
</tbody>
</table>

Inserts the “2013 Lab Requisition” custom form
If you are editing an older toolbar custom form, you can also use the following property:

**Click Event** = `insertForm("FormName")`, where you replace "FormName" with the exact name of an existing custom form or encounter assistant, within quotation marks.

Example: `insertForm("2013 Lab Requisition")`

---

**Insert Letter** toolbar item

Use the **Insert Letter** toolbar item to create a new letter in the patient chart that contains a specific letter stamp as the body of the letter.

The addressee for the letter will automatically default to the patient’s **Referring MD** (if the patient has one entered in his or her demographic information) or to “To whom it may concern” (if the patient does not have a **Referring MD**). You can change the default addressee by double-clicking it, and choosing a different one from the **Address Book**.

You must specify the following properties for this item.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource Name</td>
<td>Choose <strong>Select Stamp</strong> and choose a letter stamp.</td>
</tr>
<tr>
<td>Text</td>
<td>Type the label text to appear in the toolbar.</td>
</tr>
<tr>
<td>Click Event</td>
<td>Leave as <strong>insertLetter</strong> (do not edit).</td>
</tr>
</tbody>
</table>

**Example**

![Example Image](image-url)
If you are editing an older toolbar custom form, you can also use the following property: 

**Click Event** = letter("StampName"), where you replace "StampName" with the exact name of an existing letter stamp, within quotation marks. 
Example: stamp("RefLetterShrt").

**Insert Note** toolbar item

Use the **Insert Note** link in the toolbar template to create a new progress note in the patient chart that contains text that you specify. You must specify the following properties for this item.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource Name</td>
<td>Choose the blank area and type the text to insert in the new note. You can also use keywords.</td>
</tr>
<tr>
<td>Text</td>
<td>Type the label text to appear in the toolbar.</td>
</tr>
<tr>
<td>Click Event</td>
<td>Leave as <strong>insertNote</strong> (do not edit).</td>
</tr>
</tbody>
</table>

**Example**

```
<table>
<thead>
<tr>
<th>Resource Name</th>
<th>Hello my name is petName.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tab Order</td>
<td>0</td>
</tr>
<tr>
<td>Editable</td>
<td>True</td>
</tr>
<tr>
<td>Justification</td>
<td>Left</td>
</tr>
<tr>
<td>Associated URL</td>
<td></td>
</tr>
<tr>
<td>Max Length</td>
<td>0</td>
</tr>
<tr>
<td>Link Click To</td>
<td></td>
</tr>
<tr>
<td>Click Event</td>
<td><strong>insertNote</strong></td>
</tr>
</tbody>
</table>
```

If you are editing an older toolbar custom form, you can also use the following property: 

**Click Event** = note("Text"), where you replace "Text" with the specific text that you want to include in the note, within quotation marks. 
Example: note("Received signed patient consent.")
Insert Stamp toolbar item

Use the Insert Stamp item in the toolbar template to create a new progress note in the patient chart that contains a specific stamp. You must specify the following properties for this item:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource Name</td>
<td>Choose Select Stamp and choose a stamp.</td>
</tr>
<tr>
<td>Text</td>
<td>Type the label text to appear in the toolbar.</td>
</tr>
<tr>
<td>Click Event</td>
<td>Leave as insertStamp (do not edit).</td>
</tr>
</tbody>
</table>

Example

If you are editing an older toolbar custom form, you can also use the following property:

Click Event = stamp("StampName"), where you replace “StampName” with the exact name of an existing stamp, within quotation marks.

Example: stamp("SOAP")

Letter to Patient toolbar item

Use the Letter to Patient item in the toolbar template to send a letter to the current patient from the Records window. You must specify the following properties for this item.
### Property Description

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource Name</td>
<td>Click Select Stamp and choose a letter stamp.</td>
</tr>
<tr>
<td>Text</td>
<td>Type the label text to appear in the toolbar.</td>
</tr>
<tr>
<td>Click Event</td>
<td>Leave as letterToPatient (do not edit).</td>
</tr>
</tbody>
</table>

**Open URL toolbar item**

Use the Open URL link in the toolbar template to open a default web browser at a given URL for a website. Note that this item does not use the Resource Name property. Instead, it uses the Associated URL property. You must specify the following properties for this item.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Associated URL</td>
<td>Type the URL for the website.</td>
</tr>
<tr>
<td>Text</td>
<td>Type the label text to appear in the toolbar.</td>
</tr>
<tr>
<td>Editable</td>
<td>Ensure that the Editable property is cleared.</td>
</tr>
<tr>
<td>Resource Name</td>
<td>Leave blank.</td>
</tr>
<tr>
<td>Click Event</td>
<td>Leave as OpenURL (do not edit).</td>
</tr>
</tbody>
</table>

**Example:**

<table>
<thead>
<tr>
<th>Resource Name</th>
<th>Tab Order</th>
<th>Editable</th>
<th>Justification</th>
<th>Associated URL</th>
<th>Icon Height</th>
<th>Link Click To</th>
<th>Click Event</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td><a href="https://telushealthcommunity.force.com/">https://telushealthcommunity.force.com/</a></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Welcome to the TELUS Health Community Portal**
Perform Treatment toolbar item

Use the **Perform Treatment** item in the toolbar template to open the **New treatment** window with a treatment or immunization. You must specify the following properties for this item.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource Name</td>
<td>Choose the blank area and type the name of the treatment, immunization, or prescription favourite. You can type a partial name, such as PNEU-C-13. Leave this field blank to open a blank <strong>New treatment</strong> window. You can also type multiple treatments, immunizations, or favourites, separated by a comma, semi-colon, or + sign.</td>
</tr>
<tr>
<td>Text</td>
<td>Type the label text to appear in the toolbar.</td>
</tr>
<tr>
<td>Click Event</td>
<td>Leave as <strong>performTreatment</strong> (do not edit).</td>
</tr>
</tbody>
</table>

Example

![Example Image]

**Prescription toolbar item**

Use the **Prescription** item in the toolbar template to open the prescription window with a medication or prescription favourite. You must specify the following properties for this item.
### Property | Description
--- | ---
**Resource Name** | Choose the blank area and type the name of the medication or prescription favourite. You can type multiple medications or favourites, separated by a comma, semi-colon, or + sign.
**Text** | Type the label text to appear in the toolbar.
**Click Event** | Leave as `prescribeRx` (do not edit).

### Example

![Image of toolbar custom form](image)

When you use this prescription command from the toolbar in a patient chart, once the system enters the text in the medication name field, you can press the Tab key to move forward to the rest of the prescription fields. If you enter the exact name of an existing prescription favourite in the toolbar custom form, when you press the Tab key to move forward, all of the prescription fields are populated using data pulled from the prescription favourite.

If you are editing an older toolbar custom form, you can also use the following property: **Click Event** = `prescribe("Text")`, where you replace “Text” with the medication to prescribe or the exact name of a prescription favourite, within quotation marks.

Example: `prescribe("amox")`
Search toolbar item

Use the Search item in the toolbar to run a pre-defined search. You must specify the following properties for this item.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource Name</td>
<td>Choose Select Search and choose a search.</td>
</tr>
<tr>
<td>Text</td>
<td>Type the label text to appear in the toolbar.</td>
</tr>
<tr>
<td>Click Event</td>
<td>Leave as performSearch (do not edit).</td>
</tr>
</tbody>
</table>

Example

The search runs for all doctors in the system, unless there’s a criteria within the search to specify a doctor. If you want to customize the columns returned in the search report, you must first run the search (Records file > Patient > Search), customize the report format and save the report template with the search.

Send Email toolbar item

Use the Send Email item in the toolbar template to send an email to the current patient from Records. You must specify the following properties for this item.
**Property** | **Description**  
---|---  
**Resource Name** | Choose **Select Stamp** and choose a stamp to be used as the email message body. If you leave the **Resource Name** empty, you will be able to type your own message body for the email.  
**Text** | Type the label text to appear in the toolbar.  
**Click Event** | Leave as **sendEmail** (do not edit).  
**Tooltip Text** | By default, the email subject will be "Message from your doctor’s office." If you’d like to use a different subject, type it in this field.  

### Send Message toolbar item

Use the **Send Message** item in the toolbar template to send a message to another user (or a group of users) in PS Suite EMR. You must specify the following properties for this item. Leave a property blank to be prompted when you click the link to send the message.

| **Property** | **Description**  
---|---  
**Tooltip Text** | Type the subject of the message.  
**Section ID** | Type the initials of the recipient or a group name, such as book. Type **MD** to send the message to the patient’s doctor.  
**Resource Name** | Click the blank area and type the body of the message. Or, click **Select Stamp** to use a stamp as the body of the message.  
**Tab Order** | Type the number of days until the message is due. Type 0 to have the message due ASAP. Type -1 to be prompted when you click the link to send the message.  
**Click Event** | Leave as **sendMessage** (do not edit).  

### Example

![Click here to send a message](image)
Show Flowsheet toolbar item

Use the Show Flowsheet item in the toolbar template to open a flowsheet for the patient. You must specify the following properties for this item.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource Name</td>
<td>Choose the blank area and type the exact name of an existing flowsheet (case-sensitive).</td>
</tr>
<tr>
<td>Text</td>
<td>Type the label text to appear in the toolbar.</td>
</tr>
<tr>
<td>Click Event</td>
<td>Leave as viewFlowsheet (do not edit).</td>
</tr>
</tbody>
</table>

**Example**

If you are editing an older toolbar custom form, you can also use the following property: **Click Event** = showFlowsheet(“FlowsheetName”), where you replace “FlowsheetName” with the name of an existing flowsheet (case sensitive), within quotation marks. Example: showFlowsheet(“INR”)
Show Graph toolbar item

Use the Show Graph item in the toolbar template to graph an individual data point in the patient’s record. If you enter a vital (such as Ht: or BP:), you must follow the value by a colon. If you enter a lab value (such as chol or fbs), you don’t need a colon. You must specify the following properties for this item.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource Name</td>
<td>Choose the blank area and type the vital or data point to graph. To graph multiple vitals within the same graph window, separate them by a comma (such as Ht:,Wt:,BP:).</td>
</tr>
<tr>
<td>Text</td>
<td>Type the label text to appear in the toolbar.</td>
</tr>
<tr>
<td>Click Event</td>
<td>Leave as viewGraph (do not edit).</td>
</tr>
</tbody>
</table>

Example

<table>
<thead>
<tr>
<th>Resource Name</th>
<th>wt:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tab Order</td>
<td>0</td>
</tr>
<tr>
<td>Editable</td>
<td></td>
</tr>
<tr>
<td>Justification</td>
<td>left</td>
</tr>
<tr>
<td>Associated URL</td>
<td></td>
</tr>
<tr>
<td>Max Length</td>
<td>0</td>
</tr>
<tr>
<td>Link Click To</td>
<td></td>
</tr>
<tr>
<td>Click Event</td>
<td>viewGraph</td>
</tr>
</tbody>
</table>

If you are editing an older toolbar custom form, you can also use the following property:

Click Event = showGraph(“GraphName”), where you replace “GraphName” with a vital or a value header that exists in the chart, followed by a colon (: ) and within quotation marks.

Example: showGraph("Ht:")

Track Form toolbar item

Use the Track Form item in the toolbar template to display the most recent version of a particular custom form that was entered into the patient’s record. If the form exists in the patient’s record, the date of the most recent version of the form appears as the label next to the text label. Click the date to scroll to the form within the record.

If the form does not exist in the patient’s record, the text “never done” appears. Click this text to add this form to the patient’s record.
You must specify the following properties for this item.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource Name</td>
<td>Choose Select Custom Form and choose the custom form that you want to track.</td>
</tr>
<tr>
<td>Text</td>
<td>Type the label text to identify which form you are tracking (such as Latest CDM:)</td>
</tr>
<tr>
<td>Click Event</td>
<td>Leave as trackForm (do not edit).</td>
</tr>
</tbody>
</table>

**Example**

![Lastest CDM: Track Form](image)

**View Filter toolbar item**

Use the View Filter item in the toolbar template to quickly filter the patient’s record according to pre-defined filters (same functionality as the View menu in the Records file).

You must specify the following properties for this item.
<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource Name</td>
<td>Type one or more of the following bold filter categories below. To group multiple filter categories, separate them by a + (plus) sign. For example, Imaging shows only diagnostic imaging reports and Diagrams shows only diagrams. While Imaging + Diagrams shows both.</td>
</tr>
<tr>
<td></td>
<td>- Data (shows only data that you produced)</td>
</tr>
<tr>
<td></td>
<td>- Notes (shows only progress notes)</td>
</tr>
<tr>
<td></td>
<td>- Letters (shows only letters)</td>
</tr>
<tr>
<td></td>
<td>- Treatments (shows only treatments or allergies)</td>
</tr>
<tr>
<td></td>
<td>- Diagrams (shows only diagrams)</td>
</tr>
<tr>
<td></td>
<td>- Imaging (shows only diagnostic imaging reports)</td>
</tr>
<tr>
<td></td>
<td>- Tests (shows only diagnostic test reports)</td>
</tr>
<tr>
<td></td>
<td>- Reports (shows only consultants’ reports)</td>
</tr>
<tr>
<td></td>
<td>- Labs (shows only lab results)</td>
</tr>
<tr>
<td></td>
<td>- Custom Forms (shows only custom forms or encounter assistants)</td>
</tr>
<tr>
<td></td>
<td>- Consults (shows only pending consultations)</td>
</tr>
<tr>
<td></td>
<td>- Contains=? (prompts you for text and shows only notes that contain that text - same functionality as View &gt; Only Notes Containing)</td>
</tr>
<tr>
<td>Text</td>
<td>Precede the filter category with the word My to limit it to only notes that you created or modified. For example the filter Letters shows all letters in the chart, while the filter My Letters shows only those letters with your initials on them.</td>
</tr>
<tr>
<td></td>
<td>Precede the filter category with the word Dr to limit it to only notes that were created or modified by any doctor in the clinic.</td>
</tr>
<tr>
<td>Click Event</td>
<td>Type the label text to appear in the toolbar.</td>
</tr>
<tr>
<td></td>
<td>Leave as viewFilter (do not edit).</td>
</tr>
</tbody>
</table>
Example

View Form toolbar item

Use the View Form item in the toolbar template to view a single custom form or encounter assistant in a separate viewing window (same as View > Custom Form (F2)). You must specify the following properties for this item.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource Name</td>
<td>Choose Select Custom Form and choose a custom form or encounter assistant.</td>
</tr>
<tr>
<td>Text</td>
<td>Type the label text to appear in the toolbar.</td>
</tr>
<tr>
<td>Click Event</td>
<td>Leave as viewCustomForm (do not edit).</td>
</tr>
</tbody>
</table>
Example

If you are editing an older toolbar custom form, you can also use the following property:

**Click Event** = viewForm("FormName"), where you replace “FormName” with the exact name of an existing custom form or encounter assistant, within quotation marks.

Example: viewForm("2013 Lab Requisition")

**View Handout** toolbar item

Use the **View Handout** item in the toolbar template to open a handout in an external viewer. Only handouts in PDF format are supported. You must specify the following properties for this item.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource Name</td>
<td>Choose the blank area and type the exact name of an existing PDF handout.</td>
</tr>
<tr>
<td>Text</td>
<td>Type the label text to appear in the toolbar.</td>
</tr>
<tr>
<td>Click Event</td>
<td>Leave as <code>viewHandout</code> (do not edit).</td>
</tr>
</tbody>
</table>

If you want to use a non-pdf handout, use the “printHandout” click event property:

**Click Event** = printHandout("HandoutName"), where you replace “HandoutName” with the exact name of an existing handout, within quotation marks.

Example: printHandout("Colonoscopy Pred")
Example

List toolbar item

Use the List of Stuff item in the toolbar template to create a drop-down list of content that users can add to the patient’s record. You can copy and include as many lists as you want and each list can include any number or different types of items. For example, your list can include a mix of stamps, diagrams, letters, custom forms, prescriptions, and so on. You must specify the following properties for the list.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource Name</td>
<td>Type a unique name for each list. For example, type stamplist1 or diabeteslist2.</td>
</tr>
<tr>
<td>Event Triggered</td>
<td>Leave as selectFromList (do not edit).</td>
</tr>
</tbody>
</table>

Then you must configure the individual items that you want available in the list elsewhere within the custom form, and make those items NOT visible. You must specify the following properties for the list.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Visible</td>
<td>Leave cleared. You want the items to appear only in the list, and not as single-click items.</td>
</tr>
<tr>
<td>Section ID</td>
<td>Type the same value as you typed for the list’s Resource Name. For example, type stamplist1 or diabeteslist2.</td>
</tr>
<tr>
<td>Resource Name</td>
<td>Select or type the name of the item to insert or view.</td>
</tr>
<tr>
<td>Click Event</td>
<td>Do not edit.</td>
</tr>
</tbody>
</table>
Example

Choose a form

Forms available in formlist1:

- Lab Req
- Absentee Note
- Parking Permit

<table>
<thead>
<tr>
<th>Resource Name</th>
<th>formlist1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tab Order</td>
<td>0</td>
</tr>
<tr>
<td>Items</td>
<td>Please Select...</td>
</tr>
<tr>
<td>Event Triggered</td>
<td>selectFromList</td>
</tr>
<tr>
<td>Cycle State With Click</td>
<td>0</td>
</tr>
<tr>
<td>Custom Height</td>
<td>0</td>
</tr>
<tr>
<td>Visible Row Count</td>
<td>0</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Visible</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Opaque</td>
<td></td>
</tr>
<tr>
<td>Event Handlers</td>
<td></td>
</tr>
<tr>
<td>Tooltip Text</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Section ID</th>
<th>formlist1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Lab Req</td>
</tr>
<tr>
<td>Font Name</td>
<td>Helvetica</td>
</tr>
<tr>
<td>Size</td>
<td>9</td>
</tr>
<tr>
<td>Style</td>
<td>plain</td>
</tr>
<tr>
<td>Width</td>
<td>85</td>
</tr>
<tr>
<td>Required</td>
<td></td>
</tr>
<tr>
<td>Show Edit Text Border</td>
<td></td>
</tr>
<tr>
<td>Include In Printout</td>
<td></td>
</tr>
<tr>
<td>Compact Stamp Text</td>
<td></td>
</tr>
<tr>
<td>Graph As</td>
<td></td>
</tr>
<tr>
<td>Graph Date Field Id</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Resource Name</th>
<th>2013 Lab Requisition</th>
</tr>
</thead>
</table>
You can also type the exact name of an existing item within the **Items** property, and separate items by a comma, semi-colon, or + sign. Each items specified will appear within the drop-down list. For the drop-down list item, define the **Items** property to select the items that appear within the drop-down list:

- Click **Add** to insert a single item at the bottom of the list.
- Click **Insert Before** to insert an item before another item in the list.
- Click **Add Batch** to insert multiple items at once. Enter one item per line. The items will appear in the order entered.
- Click **Remove** to remove one item at a time.
- Click **Clear** to remove all items at once.

**Use as picker toolbar item**

Use the **use as picker** item when you are creating a list of items to choose from. For example, instead of using a drop-down list to select from a list of requisitions, you can have a button that displays the list. The list of requisitions is the "picker" form, and the **Add to Notes** option is not available. Using a picker instead of a drop-down list allows more room for displaying the name of the items in the list, and you can format the list in any way you’d like.

You must specify the following properties:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Checked</strong></td>
<td>If selected, the picker window closes after you select a resource. This is useful for lists where you generally will select only one item from the list. If not selected, the picker window stays open after you select a resource. This is useful for lists where you need to select multiple items from the list.</td>
</tr>
<tr>
<td><strong>Name</strong></td>
<td>Leave as <strong>autoclose</strong> (do not edit).</td>
</tr>
<tr>
<td><strong>Text</strong></td>
<td>Leave as <strong>use as picker</strong>, do not edit.</td>
</tr>
</tbody>
</table>

Create your list of items, using the available toolbar resources. For our requisition picker example, each item in the picker would be an **insertCustomForm** item.
Example toolbar that triggers a requisition picker

Show overdue items toolbar item

Use the **Show overdue items** item in the toolbar template to create a visual alert when an item is overdue. Overdue alerts can be a text field or a shape. You can include as many alerts as you want in a toolbar. You must create two items:

- An item to show the date that you want to track
- An item to show the overdue alert.

First, you must configure an item to show the date of the care item you want to be alerted to when it is overdue. Create a text field and specify the following properties:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Name</strong></td>
<td>Enter the name of the care item followed by &quot;Last Done&quot;. For example, type &quot;Mammogram Last Done&quot; or &quot;HbA1C Last Done.&quot;</td>
</tr>
<tr>
<td><strong>Text</strong></td>
<td>Using the <strong>Patient Property...</strong> inspector, select the desired care item and choose to display the date of latest. For example, select <strong>Patient Property... &gt; Diagnostic Imaging &gt; Mammogram &gt; date of latest</strong>.</td>
</tr>
</tbody>
</table>
Now you must configure the overdue alert. You can use the red rectangle provided on the toolbar template or you can create your own shape and colour. You must specify the following properties for the overdue item:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>You must match the name of the item you are tracking, suffixed with &quot;Due&quot;. For example, &quot;Mammogram Due&quot; or &quot;HbA1C Due&quot;.</td>
</tr>
<tr>
<td>Section ID</td>
<td>Leave as Overdue (do not edit).</td>
</tr>
</tbody>
</table>

**Show abnormal values toolbar item**

Use the abnormal alert item in the toolbar template to create a visual alert when an item is outside of a defined range. For example, you may want a visual alert when the latest PHQ-9 value is over 25. You must create three items:

- An item to show the latest value of the element that you want to track
- An item to show the abnormal value alert
- An item to set the target of the element you want to track.

First, you must configure the item to show the latest value of the care item you want to be alerted to when it is abnormal. Create a text field and specify the following properties:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Enter a unique name of the care item. For example, type PHQ9 or HbA1C.</td>
</tr>
<tr>
<td>Text</td>
<td>Using the Patient Property… inspector, select the desired care item and choose to display a numeric value.</td>
</tr>
<tr>
<td>Resource Name</td>
<td>Enter the frequency interval for the care item, using d, m, or y. For example, if the frequency for the care item is every 12 months, enter 12m in the Resource Name.</td>
</tr>
<tr>
<td>Click Event</td>
<td>Do not edit.</td>
</tr>
</tbody>
</table>
Next, you must configure the abnormal value alert. You can use the H/L indications seen on the toolbar template or you can create your own visual indication (such as a shape and colour). You must specify the following properties for the abnormal item.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>You must match the name of the item you are tracking, suffixed with &quot;Abn&quot;. For example, &quot;PHQ9 Abn&quot; or &quot;HbA1C Abn&quot;.</td>
</tr>
<tr>
<td>Visible</td>
<td>Ensure the item is not visible (unchecked).</td>
</tr>
</tbody>
</table>

Now you must configure the target for the value that you are tracking. Any value outside of this target will show the abnormal alert.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>You must match the name of the item you are tracking, suffixed with &quot;Target&quot;. For example, &quot;PHQ9 Target&quot; or &quot;HbA1C Target&quot;.</td>
</tr>
<tr>
<td>Text</td>
<td>Define the targets for the care item. For example, &quot;&lt;0.06&quot;, &quot;&gt;14&quot;.</td>
</tr>
<tr>
<td>Section ID</td>
<td>Leave as Targets (do not edit).</td>
</tr>
</tbody>
</table>

**Most recent date toolbar item**

You can use the toolbar to compare a selection of dates and display only the most recent date. This is helpful for tests that are reported in multiple ways. For example, pap smears that are reported as lab values or as diagnostic test results. The most recent date toolbar item will display the most recent date of the test, regardless of how the result was reported. You must create two types of items:

- An item to show the most recent date
- Items to list the most recent date of the test reported in each of the various ways. These are the dates that will be compared.

First you must specify the following properties for the Most recent date item.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource Name</td>
<td>Type a unique name. For example, &quot;Pap smear dates&quot;.</td>
</tr>
<tr>
<td>Section ID</td>
<td>Leave as Most recent date (do not edit).</td>
</tr>
</tbody>
</table>

Then you must configure the individual items that you want the Most recent date item to compare, and make those items NOT visible. For example, the most recent date of the pap smear lab result and the most recent date of the pap smear diagnostic test result. You must specify the following properties for the possible dates:
<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Visible</td>
<td>Do not select. These items are only used to determine the most recent date and are not themselves displayed.</td>
</tr>
<tr>
<td>Section ID</td>
<td>Enter the same name as the Most recent date item’s Resource Name. For example, &quot;Pap smear dates&quot;.</td>
</tr>
<tr>
<td>Text</td>
<td>Using the Patient Property… inspector, select the desired care item and choose to display a date value.</td>
</tr>
<tr>
<td>Click Event</td>
<td>Do not edit.</td>
</tr>
</tbody>
</table>
Troubleshooting custom forms

Why does content appear shifted when printing a custom form?

A custom form may look fine on screen, but when printed, all data is shifted from the top left corner. The problem may not be too noticeable near the top left corner, but becomes more pronounced near the bottom right corner. For example, see the Xs in the boxes in the following screen shot:

![](image)

This may happen because you are not using the proper scale factor or if the PNG image and the PDF file are not the same size. Try the following fixes.

Using recommended scale factors

We recommend using the following scale factors:

- 0.48 scale factor if creating .PNG files using Preview on Mac OS 10.6 and later
- 0.50 scale factor if creating .PNG files using Preview on Mac OS 10.4 or 10.5
- 0.48 scale factor if creating .PNG files using Acrobat Pro on Windows

Re-importing the PNG image

If you are using the correct scale but the custom form is still not printing correctly. What is causing this?

In the forms editor and the patient chart, the system uses and displays the PNG image. When printed, the system uses the PDF. So, if the PDF and PNG aren't exactly the same “physical” size, when the custom form is printed, it looks like the fields don’t line up correctly.
If you encounter such a scaling issue, from the forms editor toolbar, choose File > Utilities > Export Source PDF.

That will export the PDF that was being used to create the custom form. From there create a new PNG image.

Then rebuild the custom form using the PDF you just exported and the new PNG image that was created.

Alternatively if the PNG image is not working, try creating a JPG image instead.

How do I prevent Xs in checkboxes from being clipped when printing a custom form?

Adjust the Custom Height property of the checkbox or radio button element. The custom height allows you to adjust how much of the entire checkbox is displayed.

A best practice is to make the height of the checkbox 25% bigger than the font size (for example, if the font size is set to 10, the custom height should be 13; if the font size is 9, the custom form height should be 11).

How do I fix a printed custom form where the content cuts off and prints on a second page?

As you are creating your custom form, always stay within the blue outline in the forms editor. All graphic elements and text outside of the blue outline will not be printed.

To fix this problem, edit the custom form and re-align all the elements within the blue border.

How do I make custom forms collapse by default when I open a patient Chart?

You can customize a custom form so that it collapses by default when you open a patient chart. This greatly reduces the length of a chart. From the forms editor toolbar, choose Custom Form > Hide the Form in Notes View by Default.

For more information, see "Collapsing the custom form by default in patient charts" on page 73.
How do I prevent users from using custom forms that are not finished?

When you are working from a live (production) system to create your custom form, we suggest that you add "DO NOT USE" to the name of your form. Once your form is fully tested and ready for production, rename it to remove this text.

How can I reduce the size of a custom form that displays too large in patient charts?

You can reduce the onscreen scale of a custom form to make the form visibly smaller within the patient’s chart. You can set the scale to a value between 1.00 and 1.50, where 1.00 makes the form look smaller in the chart and 1.50 makes the form look bigger. By default, the onscreen scale is set to 1.50.

You can change the onscreen scale for any custom form (created from scratch, built using an image or a PDF).

To change the scale, from the forms editor toolbar, choose Custom Form > Set Onscreen Scale.

What is the difference between inserting and viewing custom forms (F2)?

There are two different ways to insert and fill out a custom form in a patient chart.

**Inserting a new custom form (Ctrl+Shift+i (Ctrl+z+i))**

If you want to add patient data in a custom form and keep a permanent record of the data, insert a new custom form in a patient chart from the Records file using the Data > New Custom Form menu (Ctrl+Shift+i (Ctrl+z+i)).

**Viewing a custom form (F2)**

If you simply want to view or print a custom form, with no permanent record of what you are doing, from the Records file, choose View > View Custom Form (F2 {Option+F2}).

How do I draw perfectly straight lines?

To keep lines perfectly vertical or horizontal in custom forms, press and hold the Shift key while you draw the line. You can also set the following properties on the line object:
To ensure that a horizontal line is completely straight, set the **Height** property to 0.

To ensure that a vertical line is completely straight, set the **Width** property to 0.

I created a new custom form to replace an existing form. What should I do with the existing one?

You can safely deactivate any custom form, even if it was used in a patient chart. Deactivating a custom form removes it from the list of available forms, but does not affect or delete any forms that were added in patient charts.

Before deactivating a custom form, ensure that the entire clinic no longer wants to use that form. A deactivated custom form can still be reactivated if it was removed by error. However, be aware that reactivating custom forms reactivates all forms that were previously deactivated. For more information, see "Removing a custom form" on page 77.

Can I hide some parts of an image when my custom form is based on an image?

Yes. You can add white shapes on top of the image that you use in your custom form to hide certain areas. For more information, see "Hiding parts of an image in a custom form" on page 31.
Index

.B
background images
    custom forms 28
borders
    custom forms 27
Button tool 54
buttons
    custom forms 19, 54
    see also user interface elements 52

.C
checkboxes
    see also user interface elements 52
checkboxes
    custom forms 19, 52
circles
    see also shapes 44
collapsible sections in custom forms 70
collapsing
    custom forms 10
combo boxes
    custom forms 19, 53
    see also user interface elements 52

custom forms 18-19, 77
    adding instructions 72
    adding user interface elements 52
    aligning elements 64
    background images 28
    buttons 19, 54
    checkboxes 19, 52
    collapse in patient chart 73
    collapsing 10
    combo boxes 19, 53
    creating from images 28
    creating from PDF 32
    creating from scratch 22
    custom scripts 67
deactivating 77
defaults 73
designing 36
drawing toolbar 19
editing 12, 75
ellipses 44
event handlers 66
event triggers 66
events 65
exporting 12
F2 8
flowsheet properties 59
flowsheets 19, 59
graphs 19, 49
hiding 10
importing 10
inserting 8
inserting text 38
inserting user interface elements 52
inserting vs viewing 118
landscape format 35
letters 77
lines 44
locking system 74
mandatory fields 69
methods for creating 27
names 21
navigating 18
onscreen scale 23, 118
overview 6
page breaks 19, 58
page height 26
page layouts 25
picture properties 47
pictures 19
printer margins 27
properties 23
properties pane 21
radio buttons 19, 52
rectangles 44
reminders 74
reordering elements 64
resizing elements 63
revision history 76
searching for elements 37
selecting elements 37
shapes 19
signature properties 62
signatures 61
static text 38
tab order 65
testing 75
text 19
text areas 40
text properties 41
tips for measuring/placement 22
toolbars 14
troubleshooting 116
using previous values 73
viewing 8
custom scripts
custom forms 67

D
defaults
custom forms 73
designing
custom forms 36
drawing toolbar
custom forms 19

E
ellipses
custom forms 44
see also shapes 44
EMR
custom forms 18
event handlers
custom forms 66
event triggers
custom forms 66
events
custom forms 65
exporting
custom forms 12

F
F2
viewing custom forms 8
flowsheets
custom form properties 59
custom forms 19, 59

G
GIF files
custom forms 28
graphs
custom forms 19, 49
guidelines
building a custom forms 27
creating custom forms 22
H
hiding
  custom forms 10

I
image formats
  custom forms 28
images
  as basis for custom forms 28
importing
  custom forms 10
instructions
  custom forms 72

J
JPG/JPEG files
  custom forms 28

L
landscape format
  custom forms 35
letters
  attaching custom forms 77
  custom forms 18
lines
  custom forms 44
  see also shapes 44
locking system
  custom forms 74

M
mandatory fields in custom forms 69
methods
  creating custom forms 27

N
name properties
  custom forms 21

O
onscreen scale
  custom forms 23

P
page breaks
  custom forms 19, 58
page height
  custom forms 26
page layouts
  custom forms 25
patient charts
  collapse custom forms 73
  custom form defaults 23
PDF files
  as basis for custom forms 32
pictures
  custom form properties 47
  custom forms 19, 28
pixels
  custom forms 22
PNG files
  custom forms 28
  importing in custom forms 34
points
  units of measure 22
printer margins
  custom forms 27
printing
  custom forms 8
properties
  flowsheets in custom forms 59
  signatures in custom forms 62
properties pane
  custom forms 21
R
radio buttons
  custom forms 19, 52
  see also user interface elements 52
rectangles
  custom form borders 27
  custom forms 44
  see also shapes 44
reminders
  custom forms 74
restoring when deactivated 77
revisions
  custom forms 76

S
scaling images
  custom forms 28
scripts
  custom forms 67
selecting elements
  custom forms 37
shapes
  custom forms 19
  see also circles 44
  see also ellipses 44
  see also lines 44
  see also rectangles 44
  see also squares 44
signatures 19
  custom form properties 62
  custom forms 19, 61
squares
  see also shapes 44
stamps
  custom forms 18
static text
  custom forms 38
  see also text 38

T
tab order
  custom form elements 65
testing
  custom forms 75
text
  custom form properties 41
  custom forms 19
  inserting in custom forms 38
  see also static text 38
  see also text area 38
  see also text field 38
text area
  see also text 38
text areas
  custom forms 40
text field text
  see also text 38
TIF/TIFF files
  custom forms 28
toolbar
  custom forms 14
  activating 14
  designing 84
  using 16
troubleshooting
  custom forms 116

U
user interface elements
  custom forms 52
  inserting, custom forms 52
  see also buttons 52
  see also checkboxes 52
  see also combo boxes 52
  see also radio buttons 52

V
versions
  custom forms 76
X-axis
  custom forms 22

Y-axis
  custom forms 22

- "Why does content appear shifted when printing a custom form?" on page 116
- "How do I prevent Xs in checkboxes from being clipped when printing a custom form?" on page 117
- "How do I fix a printed custom form where the content cuts off and prints on a second page?" on page 117
- "How do I make custom forms collapse by default when I open a patient Chart?" on page 117
- "How do I prevent users from using custom forms that are not finished?" on page 118
- "How can I reduce the size of a custom form that displays too large in patient charts?" on page 118
- "What is the difference between inserting and viewing custom forms (F2)?" on page 118
- "How do I draw perfectly straight lines?" on page 118
- "I created a new custom form to replace an existing form. What should I do with the existing one?" on page 119
- "Can I hide some parts of an image when my custom form is based on an image?" on page 119